Internet technologies and communication software



Filter do not delete from server
Search  Users  Rules 
Close
Login:
Password:
Forgot your password?
Register
Login
 
Pages: 1
RSS
Filter do not delete from server, There is no way to make a filter delete from my server
 
My server can put the words [SPAM] on e-mails that it thinks are spam.
I'm try to create a filter taht will delete those emails from the server automatic, but it's not happening at all.
my filter test the subject if it CONTAINS [spam] or [SPAM]

if it does match,
-mark the message as read
-move to the folder \\email\Junk
-delete the message from server

the filter mark as read and move to the JUnk, but do not delete from the server.
never.

what I'm doing wrong?
Thank you
----
 
Does the folder \\email\Junk belong to a different account or is it a common folder?
If so then set the 'delete from server' action before the move action.
__________________________________
I'm just a user of The Bat! I don't work for Ritlabs.
 
the \\email\Junk is in each account as a unique folder for that account.

I move the 'delete from server' as a first action, but still the same issue.
----
 
More info:
I have TheBat 4.0.34
then if I try to upgrade, it tells me that I have a registration for version 3.
how is that possible?
could be that I have something corrupt on my version?
this is why filters are not working?
----
 
Does the 'delete from server' fail on different pop3 servers or just on one?
Do you delete messages after some time or do you keep them indefinitely on the server?

V3 registrations are valid for v4.0 versions too. For V4.1 and higher you need to upgrade to a V4 registration.
__________________________________
I'm just a user of The Bat! I don't work for Ritlabs.
 
I delete the files from the server every night when I go home and check e-mails from there.
During the day I check e-mails from my lap-top.
The main idea on having this is when I'm on the road for a week, getting home I only have to download the real emails, and not the 12.303 junk that fill the inbox :)

I will look into upgrading my copy.
----
 
I change my filter order, so the delete now is the first command. Still not deleting from the server on the first pass.
If I re-filter, some (not all) of SPAM are deleted...
could not find a rule for which ones are deleted which ones are not.
I will buy the upgrade TheBat today and try again. Maybe this previous version has a bug on the filter???
I hope to get the issue fix with the new version
will post here if works or not later today.
----
 
do you still have problem with it?
 
If I correctly remember, deletion from server happens with the next fetch.

If you fetch messages and some of them trigger a filter with delete from server action, these will not be deleted in this session but the next time you fetch messages
At least it works that way in v3.85 that I mainly use, v4 may work differently.
Pages: 1
Users browsing this topic (1 guests)