Internet technologies and communication software



Filter does not seem to work as advertised
Search  Users  Rules 
Close
Login:
Password:
Forgot your password?
Register
Login
 
Pages: 1
RSS
Filter does not seem to work as advertised
 
I am trying to set up a filter to catch messages sent fr om an automated system. The RFC-822 header suitably anonymised is at the bottom.

I've tried "Recipient contains 'my address'" , but as there's no "To:" field this doesn't seem to work. There is the "X-Envelope-to" field though.

I've tried "Subject contains 'Topic Reply'" and "Subject starts with 'Topic Reply'" but these don't work. I don't know why not. Are the spaces giving a problem?

Wh ere do I go from here, please?

RFC-822 header:

Return-Path: <apache@anbmv0002.oracle.com>

Delivered-To: my mailbox address

Received: (qmail 17500 invoked from network); 8 Jul 2012 12:52:25 -0000



To:

Subject: Topic Reply Notification - Questions about version control

X-PHP-Originating-Script: 500:emailer.php

Reply-to: webmaster@netbeans.org

From: webmaster@netbeans.org

Message-ID: <60b34ed52c37ec0fc85a04a4c047004a@forums.netbeans.org>

MIME-Version: 1.0

Content-type: text/plain; charset=iso-8859-1

Content-transfer-encoding: 8bit

Date: Sun, 08 Jul 2012 08:52:16 -0400

X-Priority: 3

X-MSMail-Priority: Normal

X-Mailer: PHP

X-MimeOLE: Produced By phpBB2

X-Source-IP: ucsinet22.oracle.com [156.151.31.94]

X-Original-Ip: 148.87.113.117

X-Scanned-In: 5.12secs

X-SA-SPAM-Flag: No

X-Spam-Score: -2.598/6 AWL,BAYES_05,RCVD_IN_DNSWL_HI,RDNS_NONE,REPLYTO_WITHOUT_TO_CC,TO_NO_BRKTS_MSFT

X-Scanned-By: Spam Filtering on spam6.interdns.co.uk

X-Envelope-To: my address
Peter
 
The subject starts with Topic Reply filter should work properly.
Other options for a filter are possible too.
However, keep in mind that once a message has triggered a filter, that message won't trigger any other filters. Unless the first triggered filter had the option 'continue processing with other filters' enabled.
So to be sure that these messages aren't triggered by other filters you should place this filter as the first one in your sorting office for this account.

You could also disable
Account -> Properties -> Options -> Verbose log
When that's disabled your log mentions the filter actions, so that you can figure out what filters process certain messages
__________________________________
I'm just a user of The Bat! I don't work for Ritlabs.
 
Solved it - silly me. the filter was on the outbound tree, not the inbound one! But the filter window's rather small and I have about 50 filters, so I can't see the root of the tree.

All my fault. :)
Peter
Pages: 1
Users browsing this topic (1 guests)