Ritlabs



Failure to download mail from pop.gmail.com

Search  Users  Rules 
Close
Login:
Password:
Forgot your password?
Register
Login
 
Pages: 1
RSS
Failure to download mail from pop.gmail.com, the server host name (pop.gmail.com) does not match certificate
 
Hello,
The Bat worked fine with Gmail for years (downloading from pop3).
Today in the log it gives out an error message:

Code
the server host name (pop.gmail.com) does not match certificate 

http://ipic.su/img/img7/fs/SnapShot_140523_233820.1400874531.jpg

How do I fix it?
Is it a virus or something?
Edited: Apple7 - 23.05.2014 23:24:46 (grammar)
 
Hit support with it. I had the same thing setting up an account that was NOT a gmail account. Here are two sources for root certificates in case that is the problem (which it often can be) It did not help my issue this time however

http://secure.globalsign.net/cacert/Root-R1.crt
https://www.geotrust.com/resources/root-certificates/index.html
 
Thank you Rick.
The first link says I already have it installed.
The second doc I'm not sure to understand.
 
Yes Hit the support about that, I also have this issue very very often with Gmail. Sometimes Thebat goes right sometimes no.
 
I only encounter that issue for the first time for many years
 
There are people in the beta group that have started having similar issues . stay tuned - if a solution comes up I will post it back here
 
Thanks Rick. Waiting for the news
 
I have found a workaround on Google forums (but it's in Russian)
https://productforums.google.com/forum/#!topic/gmail-ru/K5HfmFKjAtc

In essence you need to change "pop.gmail.com" to "gmail.com" in TB settings
and in %WINDIR%\System32\drivers\etc\hosts file you need to add the following line:

Code
74.125.143.109 gmail.com



It works for me, but I would prefer to get an updated certificate from Google.
Please let me know if it gets released
 
After problems with The bat! v6.4.0 ( same as: http://www.ritlabs.com/en/forums/forum4/topic11531/ ), suddenly it doesn?t works, uninstall, reinstall doesn?t work, finally I have to use ccleaner for reinstall, I recover the backup copy and now I have the same problem:


Code
 29/05/2014, 07:20:34: FETCH - Conectando con el servidor POP3 pop.gmail.com en el puerto 995
 29/05/2014, 07:20:35: FETCH - Inicializando negociacion TLS
>29/05/2014, 07:20:36: FETCH - Certificado S/N: 0A7AA2766A688E80, algoritmo: RSA (2048 bits), emitido de 10/09/2013 7:57:39 para 10/09/2014 7:57:39, para la(s) maquina(s) 1: pop.gmail.com.
>29/05/2014, 07:20:36: FETCH - Propietario: "US", "California", "Mountain View", "Google Inc", "pop.gmail.com".
>29/05/2014, 07:20:36: FETCH - Emisor: "US", "Google Inc", "Google Internet Authority G2".
>29/05/2014, 07:20:36: FETCH - Emisor: "US", "GeoTrust Inc.", "GeoTrust Global CA".
>29/05/2014, 07:20:36: FETCH - Emisor: "US", "Equifax", "Equifax Secure Certificate Authority".
!29/05/2014, 07:20:36: FETCH - Fallo en la negociacion TLS. Certificado del Servidor Invalido (El expedidor de esta cadena de certificados no se ha encontrado).
 29/05/2014, 07:21:35: FETCH - Recibiendo mensajes
 29/05/2014, 07:21:35: FETCH - Conectando con el servidor POP3 pop.gmail.com en el puerto 995
 29/05/2014, 07:21:35: FETCH - Inicializando negociacion TLS
>29/05/2014, 07:21:35: FETCH - Certificado S/N: 0A7AA2766A688E80, algoritmo: RSA (2048 bits), emitido de 10/09/2013 7:57:39 para 10/09/2014 7:57:39, para la(s) maquina(s) 1: pop.gmail.com.
>29/05/2014, 07:21:35: FETCH - Propietario: "US", "California", "Mountain View", "Google Inc", "pop.gmail.com".
>29/05/2014, 07:21:35: FETCH - Emisor: "US", "Google Inc", "Google Internet Authority G2".
>29/05/2014, 07:21:35: FETCH - Emisor: "US", "GeoTrust Inc.", "GeoTrust Global CA".
>29/05/2014, 07:21:35: FETCH - Emisor: "US", "Equifax", "Equifax Secure Certificate Authority".
!29/05/2014, 07:21:35: FETCH - Fallo en la negociacion TLS. Certificado del Servidor Invalido (El expedidor de esta cadena de certificados no se ha encontrado).

Regards
 
Thanks Apple7, this worked fine for me too!
Quote
39790 wrote:
I have found a workaround on Google forums (but it's in Russian)
https://productforums.google.com/forum/#!topic/gmail-ru/K5HfmFKjAtc

In essence you need to change "pop.gmail.com" to "gmail.com" in TB settings
and in %WINDIR%\System32\drivers\etc\hosts file you need to add the following line:
Code
 74.125.143.109 gmail.com 

Best,
Gorel
 
Just a word of caution: if it stops working again, remember to delete that line before troubleshooting (or just comment it out) If they change IPs or move you to a different server that fix will fail (and pinging pop.gmail.com will get you the new IP)
I am on74.125.143.108
 
Thanks Rick! I've also thought of this. That is why I would prefer to solve the cert. issue drectly.
Quote
39822 wrote:
10 8
It also resolves to 108 on my comp. But 109 works as well.


Quote
39786 wrote:
people in the beta group that have started having similar issues
Was there any solution suggested?
 
Hi,

Try with this of Ritlabs Support:


Code
Try switching from "Internal Implementation (The Bat! Address Book)" to "Microsoft Crypto API" under the "Options\S/MIME and TLS -> S/MIME and TLS Certificates" menu and see whether it works.

Works for me

Thanks

Regards
 
I got a new certificate (automatically).
So to make it work again I had to change the TB pop3 settings back to 'pop.gmail.com'

http://ipic.su/img/img7/fs/SnapShot_140604_111325.1401866191.jpg

It took Gmail only 12 days to fix the issue)))
Edited: Apple7 - 04.06.2014 10:26:16 (sarcasm added)
Pages: 1
Users browsing this topic (2 guests)