Pages: 1
How to Override "From"/"Reply To" Info
I need to have my emails say they're coming from another address with both the "from" and "reply to" info.

I used the macro


which works fine, but the macro


does not override the original "from" information and my email never shows up in my inbox when i test it. Not sure if it matters buy my host is hostgator. I need to get this to work quickly, appreciate any help on this. Thanx!  8)
Just tried  it, created a folder template with the macro %From="my name <my other address>" and it worked just as intended.
So there must be something wrong with the way you've set it up.
What kind of template are you using to achieve your goal, an account template, a folder template, an address book template or a quick template? And if you're using a folder template and you only adapted your new message template and are testing with reply templates....
Furthermore you should realise that when you're testing with folder templates while you are testing against an address that has address book (either private or group) templates enabled, the folder template will ignored , because address book templates take precedence over folder templates and folder templates take precedence over account templates.
Also the %account= macro overrules the %from= macro when it's placed later in the template. (Previous versions alsop had a bug in this regard.) What version are you using?
I'm just a user of The Bat! I don't work for Ritlabs.
I'm using 4.2.6.

Not sure the name of the template, but i made it as a reply to rules I set up in filters. So if a certain rule is matched it sends this reply with which i have the macros setup.

I just tried it again with your syntax and still doesn't work.

I honestly think it might be my host preventing this functionality.
Ah, a filter template. Didn't think of those. However I couldn't think of a reason the %From= maco shouldn't work in those.
So I tested it and created for one of my accounts an autoreply filter (for messages from my main address) that replied to me with "B. Obama" <> in the from header and that worked.
The message got both sent to my main address, but it got also moved to the Sent Mail folder of the test account.
So there you can find the answer whether it's something in your setup or something by your ISP, If the messages with the alternate From: header arrive in Sent Mail, but not at their intended recipient then it's your ISP. If they aren't placed in your Sent Mail then you're doing something wrong.
I'm just a user of The Bat! I don't work for Ritlabs.
yeah i switched hosts and now everything works :)

I have a few other questions (hope you don't mind)

1. Postponed sending. The 1st day i set it up it worked perfectly, then it just stopped working (without any settings being changed). The messages just stay in the outbox indefinitely until i unclick the hourglass symbol and then it sends...but if i don't do that it never sends the message. I see in the forum that other people have had this problem, any solution for this?

2. Is it possible when you have say 20 messages in the outbox to just send 10 of them? If i don't want to send all of them at the same time, just some of them. I can't figure out a way to do this

3. I created a folder called "manual revieww" that receives all the emails that triggered a filter and needed me to look at them manually. After i review the email manually how can I bypass the filters and have it go to the outbox with my filter reply message?

Thanx a lot for your help!
1) Can't help you with that, don't use postponed sending myself

2) The only way to keep messages in your outbox while sending other messages is by parking them

3) I don't think I understand your question.
I'm just a user of The Bat! I don't work for Ritlabs.
Ok to clarify #3.

I setup filters and one of the filters sends emails to a folder I created for manual review before the reply gets sent.

So in this folder, once I look at the emails manually and determine that it's ok to send a do i send these emails to my outbox without them getting filtered all over again?

Hope this is more clear
Pages: 1