Pages: 1
The Bat crashes at startup (Exception EOleSysError)
I had the last version of the Bat installed (6.7.2) under windows 7 (64 bits) and worked fine. Yesterday I launched some antivirus and antimalwares. And after that impossible to launch The Bat. I always have the same windows error message at startup:

Exception EOleSysError  in module thebat.exe at 00150BA6
Class not registered, ClassID:

It seems to be a Delphi error? I tried to reboot, install again or to remove and reinstall but nothing works!

I tried to reinstall some archived versions. I have the same bug with 6.0.12 but it works with 5.8.8 that I can use.

But if try to upgrade from 5.8.8, I still have the same problem!   :-(

Any idea?  Thanks for your help!
I just launched AdwCleaner and it detects a problem at this same registry address:

[x64] HKLM\SOFTWARE\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}

I try to clean with AdwCleaner option, then I reboot as suggested but if I launch again AdwCleaner I always have the same problem with this registry adress.

The problem should be here but how to solve it?
Strangely when I try to open the registry with regedit command, I am not able to found the folder CLSID under HKey_Local_Machine\SOFTWARE\Classes\

Perhaps the problem is here?
sorry I found it but it's empty
Pages: 1