Pages: 1
RSS
Message Finder - search for Issue When Asteriks Used
 
Why is it that when the character * (asterik) is used, results do not appear from using the Message Finder - search for?

For example, in Trash, I am trying to serach my mail for "joseph*john". The asterik is required because the sender ID has the asterik, it must be included. I know for a fact that the mail for this person exists, but it will not show in the results. Instead, it shows all of my old mail and not specifically the ones from "joseph*john".

How can I make the search option work with asteriks (joseph*john)?

Thank you.
 
Most likely due to the asterisk being a special character for search under regular expressions.
the back slash may escape iirc

replace the '*' with a '.' period which is any single character. If works then look at the help file for regular expression information.

See: https://www.ritlabs.com/en/support/help/77/#6681 under Additional Information.  
 
Quote
Arnold DeRoy wrote:
Most likely due to the asterisk being a special character for search under regular expressions.
the back slash may escape iirc

replace the '*' with a '.' period which is any single character. If works then look at the help file for regular expression information.

See:  https://www.ritlabs.com/en/support/help/77/#6681  under Additional Information.
My problem is that I can't replace it and I have to search it with the asterisk. Is there any way to do this?
 
Quote
Arnold DeRoy wrote:
Most likely due to the asterisk being a special character for search under regular expressions.
the back slash may escape iirc

replace the '*' with a '.' period which is any single character. If works then look at the help file for regular expression information.

See:  https://www.ritlabs.com/en/support/help/77/#6681  under Additional Information.
And I found joseph*john replace the * with joseph.john is not working.
 
Did you specify the 'match' condition as explained in the URL shown? If you used the default of 'contains' it doesn't work.
 
Out of curiosity, I have made a message addressed to joseph*john@mydomain.com and I've stored it in my Sent Mail folder.

When I use the message finder in my TheBat 3.64.01 with these options (i.e. without escaping anything), the message is found just fine:

"Recipient" "Contains" "joseph*john"
 
Quote
david kirk wrote:
Did you specify the 'match' condition as explained in the URL shown? If you used the default of 'contains' it doesn't work.

Thank you very much. I have resolved the problem.
 
Quote
Daniel van Rooijen wrote:
Out of curiosity, I have made a message addressed to joseph*john@mydomain.com and I've stored it in my Sent Mail folder.

When I use the message finder in my TheBat 3.64.01 with these options (i.e. without escaping anything), the message is found just fine:

"Recipient" "Contains" "joseph*john"

Thank you! I have tried this specifically and it worked.
Pages: 1