Pages: Prev. 1 2 3 4 5 Next
RSS
TLS Handshake Failure - appreciate any help on how to fix
 
Yesterday I also have a problem, TLS Handshake Failure
I try many ways to solve it.

Luckily

This works for me:
change the smtp.gmail.com into  
smtp.googlemail.com
and change the pop.gmail.com into
pop.googlemail.com

others remain the same as before, just change the above.

Send mail:
smtp.googlemail.com
Secure to dedicated port (TLS)
Port: 465

receive mail:
pop.googlemail.com
Secure to dedicated port (TLS): Yes
Port: 995

The Bat! Professional Edition v8.8.9
 
Quote
We will research this issue ASAP and probably release an updated version of The Bat!
Sounds promising. Will you backport it to older versions of TheBat/Voyager? (in particular to Voyager v8).
 
Quote
Send mail:
smtp.googlemail.com
Secure to dedicated port (TLS)
Port: 465
Worked for me (at least for now), thanks!
 
Quote
Maxim Masiutin wrote:
We will research this issue ASAP and probably release an updated version of The Bat!
Can you give us a term, when we can expect an update of The Bat!?
 
Quote
Maxim Masiutin wrote:
We will research this issue ASAP and probably release an updated version of The Bat!
Thanks, Maxim. I look forward to once again being able to rely on TB! for sending and receiving email over the Gmail servers.
 
Message keyed in at/around 14:36 BST, April 08, 2020

Hi,
Since yesterday (07 April 2020) I am having major issues with both downloading and
sending email fr om any / all of my mailboxes on The Bat. My version is: 9.1.6 64 bit
and I have not made any changes to either my PC or to The Bat.

Each one of my mailboxes ( and I have around 25/30 set up in around 10 different
installations of The Bat on my single PC and which I open up individually as and
when I need them) is showing the TLS handshake failure error as also the invalid
certificate error. It just is not going away whether I use the port 465 or 587 or 955 etc

I have also spoken to Google (as I use GSuite - both paid version and free version)
and they can see that I am able to download and send email using MS Outlook as
also using the web browser.

So I think the issue may be with The Bat settings. Or maybe I am wrong?

I am a big supporter of The Bat and as you well know I have been using it for
more than 15 years now. You have in the past been very helpful and I hope you can
resolve this for me promptly as my work is suffering as I am not used to sending
emails from MS Outlook etc. as all of my storage is in The Bat and I need to look
at historical emails too.

I have tried sending test mails from may of my mailboxes set up on The Bat but I
am having no luck. The message does not go and just vanishes from the screen.

I have also for the past some months seen the following thing happening when I
have The Bat installations on:

....the computer screen just goes dark and flickers and when it comes back - all
The Bat settings and windows / tabs have moved and then I have to reset them
or place them wh ere they visually were earlier on. It has come up with:
Systems Errors Code 1400. Invalid Window Handle. Kindly advise.

But email issue more important please. Kindly assist. Thanks.

I have attached all Exception Logs from each of my The Bat installations.

Note: AM resending the message without the exception logs and the screenshots
as mail is bouncing back to me!

Sincerely, JJ
 
Hi,

smtp.googlemail.com does not work either. I have purchased a Bat upgrade hoping to fix this issue, unfortunately it still does not work. When can we expect  it to be fixed?

Thanks.
 
Hi All
I've had a response back from Alexander (the Great!!) at The Bat and his email went as per follows word for word:

quote
Google has started using new types of certificates on their mail servers which are not yet supported by The Bat! We are now working on implementing the new algorithms and we will soon release a new version of The Bat! which will be able to use new Gmail certificates.
unquote

This is obviously good news from The Bat but we need this quick please as using The Bat is impossible right now!

Ciao ciao!!
 
Quote
cyb0rg wrote:
...snip...

Note: If you go to Options -> S/MIME and TLS... and switch between "Internal ..." and "Microsoft ..." at the top that might help your mail to get through temporarily. I don't know if any options here will help to fix the problem long  term.
Yes, I tried this and it *** seemed *** to work, but temporarily. I switched back and forth. In the above post [and others as well], it seems like we are waiting for another update.
Edited: Frederick Smith - 08 April 2020 17:41:33
 
This issue is resolved in The Bat! version 9.1.10, it can be downloaded from https://www.ritlabs.com/en/products/thebat/download.php
 
Quote
Maxim Masiutin wrote:
This issue is resolved in The Bat! version 9.1.10, it can be downloaded from  https://www.ritlabs.com/en/products/thebat/download.php
Now it's working great on my end. Thank you!
 
Quote
Maxim Masiutin wrote:
This issue is resolved in The Bat! version 9.1.10, it can be downloaded from  https://www.ritlabs.com/en/products/thebat/download.php
Thanks, Maxim. Up and running. Successfully sent and received over Gmail. So far, so good.
Just one quick comment/observation. I wish you had released 9.1.10 on the basis of the previous MSI (9.1.6) instead of the latest Beta with its various toolbar issues (including the disappearance of toolbar buttons on minimization and restoration, which is a bit of a hassle). TB general users are not Beta testers. But that is a small issue. The big issue... Gmail certificates... does seem to be resolved, and that is much appreciated.
Edited: Jay Walker - 08 April 2020 20:38:15 (Qualification)
 
Thanks to RitLabs for the quick response. I had the same issue. Question: Will Voyager get a compatible upgrade as well, or is the 9.1.6.1 version already OK in this regard?
 
Quote
Gregg Irwin wrote:
Thanks to RitLabs for the quick response. I had the same issue. Question: Will Voyager get a compatible upgrade as well, or is the 9.1.6.1 version already OK in this regard?
Yes, you can now download Voyager  v9.1.10.1 from https://www.ritlabs.com/en/products/voyager/download.php
 

The Bat! did require "Key  Encipherment" or "Key Agreement" in "Key Usage" certificate attribute  for TLS even if the certificate was only used to sign ephemeral keys to  provide perfect forward secrecy. If a server only supports perfect  forward secrecy TLS cipher suites, the certificate used by this server  may have no "Key Encipherment" or "Key Agreement" in the "Key Usage"  attribute; only "Digital Signature" is needed in this case.

Google has started using a certificate that only had "Digital Signature" in the "Key Usage" attribute.

That caused the problem.

 
Quote
Maxim Masiutin wrote:
Quote
Gregg Irwin wrote:
Thanks to RitLabs for the quick response. I had the same issue. Question: Will Voyager get a compatible upgrade as well, or is the 9.1.6.1 version already OK in this regard?
Yes, you can now download Voyager  v9.1.10.1 from  https://www.ritlabs.com/en/products/voyager/download.php
Thanks Maxim! I upgraded, but 9.1.10 (normal, not Voyager) has painting issues on Win10, restoring from minimized. Toolbar buttons, menus, and status bar don't paint until I focus the window and mouse over them. Let me know if there's something you want me to try to narrow it down.
 
Quote
Jay Walker wrote:
Beta with its various toolbar issues (including the disappearance of toolbar buttons on minimization and restoration, which is a bit of a hassle).
You may disable (uncheck) the option "Do not put The Bat! to Windows Task Bar" and restart The Bat!, until we fix this issue.
 
It still does not work even with the version 9.1.10
The error message has changed. Now it's "SEND  - Chyba protokolu TLS: Vnitřní chyba BuildClientKeyExchange."
 
Quote
Miloslav Maun wrote:
It still does not work even with the version 9.1.10The error message has changed. Now it's "SEND  - Chyba protokolu TLS: Vnitřní chyba BuildClientKeyExchange."
It seems that the Avast Antivirus is replacing the root certificate and it somehow leads to the BuildClientKeyExchange error. That's why it probably only happens with those who use Avast, not with other users.
 
Quote
Yes, you can now download Voyager  v9.1.10.1 from https://www.ritlabs.com/en/products/voyager/download.php

Thank you Maxim. Any plans to backport it to earlier versions (in particular Voyager 8)? I assume all earlier version are affected.
 
I doubt he would do that. This is his business and that's why there is an upgrade fee: being protected from ever-changing issues for email. If he applies updates to prior versions, it eliminates the need to upgrade. However, you can change authorization from OAUTH to Regular on older versions and that works.

david
 
Quote
Maxim Masiutin wrote:
Quote
Jay Walker wrote:
Beta with its various toolbar issues (including the disappearance of toolbar buttons on minimization and restoration, which is a bit of a hassle).
You may disable (uncheck) the option "Do not put The Bat! to Windows Task Bar" and restart The Bat!, until we fix this issue.
Thanks, Maxim. I can confirm that this does resolve the problem... as does the latest version, 9.1.12.  :)  The minimization issue only applied when one has opted to always minimize to the system tray. Anyway, once again, much thanks for resolving the problem with Gmail certificates, which had me trying all types of useless things and -  :o  - even wondering what I must have done wrong for several days.
Edited: Jay Walker - 09 April 2020 14:57:46
 
Quote
Maxim Masiutin wrote:
Quote
Miloslav Maun wrote:
It still does not work even with the version 9.1.10The error message has changed. Now it's "SEND  - Chyba protokolu TLS: Vnitřní chyba BuildClientKeyExchange."
It seems that the Avast Antivirus is replacing the root certificate and it somehow leads to the BuildClientKeyExchange error. That's why it probably only happens with those who use Avast, not with other users.

Sad but true. With Avast mail scanner off, gmail works like a charm. With it on, I also get BuildClientKeyExchange Internal Error.
 
Unfortunately, I've got also this problem. For me fix doesn't work. After deleting gmail.account, and installing 9.1.10 version, sending started to work. After two hours, it stopped working. I changed logging, ports and do everything i can.
I am using GDATA antivirus software.
Sometimes the bat connect to server, sometimes fail as in log:
2020.04.09, 14:02:29: IMAP  - Łączenie z serwerem IMAP imap.gmail.com przez port 993
2020.04.09, 14:02:29: IMAP  - Inicjacja fazy potwierdzania TLS
>2020.04.09, 14:02:29: IMAP  - Nr certyfikatu: 7AC93BB147CE6636, algorytm: RSA (2048 bitów), ważny od 2020.03.19 08:48:32 do 2030.03.17 08:48:32, dla 1 węzłów: imap.gmail.com.
>2020.04.09, 14:02:29: IMAP  - Właściciel: US, California, Mountain View, Google LLC, imap.gmail.com.
>2020.04.09, 14:02:29: IMAP  - Wystawca: DE, NRW, Bochum, G Data Software AG, Generated by G Data Security Software for SSL scanning, G Data Mail Scanner Root.
2020.04.09, 14:02:29: IMAP  - Faza potwierdzania TLS zakończona
2020.04.09, 14:02:29: IMAP  - Połączono z serwerem IMAP (imap.gmail.com)
>2020.04.09, 14:02:29: IMAP  - Gimap ready for requests from 185.172.86.48 z16mb58163434ltp
2020.04.09, 14:02:29: IMAP  - Autoryzacja (użytkownik: "xxx@gmail.com", metoda: "XOAUTH2")...
2020.04.09, 14:02:31: IMAP  - Uwierzytelnienie na serwerze IMAP przebiegło pomyślnie, komunikat serwera: "xxx@gmail.com authenticated (Success)"
!2020.04.09, 14:04:13: IMAP  - The server didn't reply anything to TImapFolderCounterSearchTask command in 90 seconds
2020.04.09, 14:04:18: IMAP  - Rozłączono
2020.04.09, 14:05:19: IMAP  - Łączenie z serwerem IMAP imap.gmail.com przez port 993
2020.04.09, 14:05:19: IMAP  - Inicjacja fazy potwierdzania TLS
!2020.04.09, 14:06:48: IMAP  - Błąd fazy potwierdzania TLS: Połączenie nie powiodło się
2020.04.09, 14:06:52: IMAP  - Łączenie z serwerem IMAP imap.gmail.com przez port 993
2020.04.09, 14:06:52: IMAP  - Inicjacja fazy potwierdzania TLS
!2020.04.09, 14:07:28: IMAP  - Błąd fazy potwierdzania TLS: Połączenie nie powiodło się
2020.04.09, 14:12:33: IMAP  - Łączenie z serwerem IMAP imap.gmail.com przez port 993
2020.04.09, 14:12:33: IMAP  - Inicjacja fazy potwierdzania TLS
Edited: Radosław Olesiński - 09 April 2020 15:30:08
 
Quote
Andrzej Czerkowski wrote:
Sad but true. With Avast mail scanner off, gmail works like a charm. With it on, I also get BuildClientKeyExchange Internal Error.
Miloslav wrote that after updating Avast to latest version, it started to work properly. What version of Avast did you use that led to the BuildClientKeyExchange error?
Pages: Prev. 1 2 3 4 5 Next