Pages: 1
RSS
Filters not triggered if there is no one at computer
 
Hello everyone,
I've set up several filters on one IMAP account, in order to forward an incoming (automated) mail to certain recipients, according to it's Subject.
TheBat runs on an unattended computer, with no display, keyboard or mouse.

The automated mail arrives daily at 9:00
but - the filters are triggered only when someone is at the pc (using TeamViewer, Google Remote Desktop etc).
If there is no one on the PC, it simply does nothing. At the first move, for example a remote connection at 9:30, the filters ran immediately.

The PC is always on, with no power saving configured.

Is it any way to configure TheBat to run as a service, or maybe under different credentials, to always run the filters ?

Regards,
Ciprian
 
Are you positive that The Bat has received the mail at 9:00am (and not later)? It seems strange to me that The Bat would poll for mail but not run its filters directly afterwards.

You say "no power saving configured" but did you specifically check the power management settings for your network interface card? Even when you have disabled sleep/hibernation mode for the system as a whole, Windows may still be trying to save a few milliwatts there (if so, The Bat's log file for that mail account will show many 'cannot connect' errors). If this may be the problem, go into Windows' Device Manager, right-click on the used NIC, select Properties and check the settings on the Power Management tab.
 
Hi Daniel,

The only thing that I am 100% sure is, that the automated e-mails are created and sent between 9:00 and 9:15 (by the ERP - a different machine), and they arrive on the IMAP server.

In the very first moments after remote connection (~9:30...), TheBat is performig the connections and firing the filters - I can see the counters in the folder tree panel increasing rapidly. So I think you are right, it's not polling for e-mails until remote desktop-ing.

I've unchecked the "Allow the computer to turn off this device to save power" in the NIC power settings.

There is a checkbox in TheBat, "Periodical checking each n minutes" - imho it is useless for IMAP accounts, but I set now it for 1 minute. I'll see tomorrow morning if it has any effect.
 
The checkbox solved the problem, now it's working fine.
For reasons I cannot understand, IMAP sync needed the Periodical checking to be ON.


Regards,
ciprian
Pages: 1