Pages: 1
Common Fitler Issues, New user - Common Filters
I am trying to get filters to work.  I have read the limited documentation and here is my filter.

$$$$ TB! Message Filter $$$$
UID: [F80C2C78.01C8E11E.2A9A6B26.0177F1C0]
Name: OpenBD
Filter: {\D\A\20`7`To`0`\D\A}
Tag: OpenDB
MoveMessage folder \5C\5C\5CCommon\5Copenbd

But when I test this filter nothing happens.
How do you test it?
I'm just a user of The Bat! I don't work for Ritlabs.
I selected all of the messages in the in box and tried "test filter".

I read all of the documentation that I could find but the docs are lacking.  They mainly just tell you what you already know from looking at the interface.  Nothing is explained.
Well, the 'test filter' option doesn't work as you thought it does.
It doesn't check all selected messages, but only the message that's in focus. And when that message triggers a filter, it doesn't perform the action defined by that filter, but it tells you what action it would have performed.

Select the inbox and pick re-filter from the menu:
Folder -> Re-filter...
I'm just a user of The Bat! I don't work for Ritlabs.
OK.  I tried it by using the re-filter menu item.  Still nothing happens.  I created another filter.

$$$$ TB! Message Filter $$$$
UID: [2FD5AB4C.01C8E17F.4F617B93.5143FBE6]
Name: ePurl\20Issues
Filter: {\D\A\20`2`0`ePurl\D\A0`2`0`Issue\D\A}
MoveMessage folder \5C\5C\5CCommon\5CIssues\20-\20ePurl

I have messages with subject lines like this:
ePurl Issue: xxxx

But nothing filters!

I tried this filter with "Subject contains ePurl and Subject contains Issue" but still the messages are not filtered.

This is a windows XP 64bit machine with all the lastest patches.
What version of the bat are you using?

Do you realize that filters are account related? So filters created in account A won't be triggered by messages in accout B? Common filters can be triggered by all accounts, but you've got to select those accounts in the 'Share with...' tab of the common filter.
I'm just a user of The Bat! I don't work for Ritlabs.
I am using The Bat 4.0.24.  I am using common filters and I made sure that the "share with .." options are set correctly.

Nothing is filtered no matter what I do.  This can't be this hard to configure.

I tried individual account filters and common filters.  I tried "incoming mail" and "read messages" filters nothing works.
Edited: Andrew Penhorwood - 09 July 2008 18:09:25

Not sure what happened but your last message is not showing up in the forum.  But I did get the email.  Strange.

I have a normal install of "The Bat".  Not sure what you are saying about the \D\A stuff as the example looks the same to me.  Maybe I am missing something.

I guess I could reinstall.  Can I do that without effecting all of the email I have inside of the bat?  I inported my email from my old Eudora program.


Some of the garbling of the filter is caused by the forum software, therefore I deleted my message.

Were the filters that you posted the first filters you created?
If so then you could try to delete the filter files and try again without installing TB again.

Close TB
Delete the account.srb files in your mail directory and in the directories matching your accounts.
Start TB and try to create your filters again.

If I interpreted your filters correctly, you were using the condition 'header field: To' contains ''
My suggestion would be to use the condition
'recipient' contains ''
And take care that you don't copy any spaces along with the address, that would mean that your filter would be looking for those spaces too.
And use the incoming filters of the account that actually receives the messages.
Until you've got proper filters functioning I'd advise against using common filters at all. (For myself I still don't use them even thopugh I've got more than 100 filters running)

I'm just a user of The Bat! I don't work for Ritlabs.

Thanks, deleting the account.srb files seems to have fixed it.  I avoided the commom filters and just added them to the main account.

Yes the common filter was the 1st filter I created so maybe there is a bug there.  I have it working now.

Thanks again.

Pages: 1