Pages: 1
Installing SSL certificate, How to install SSL certificate when option grayed out in pop up warning?
I've added an email account which uses Startcom as SSL certificate authority. TB keeps popping up a warning that there is no certificate, and won't let me install one, because the option is grayed out.

I've copied the *.crt certificate file fr om another email client I was using. Can anyone tell me wh ere I should put it so that TB will recognize it, install it, and stop flashing up a warning?

Many thanks!
I had the same problem form an year.
Unfortunately I have tried more solutions without results :(
Open the address book and FILE / IMPORT and choose a certificate
You are on your own after that as I don't have experience with that certificate authority
Sometime the bigger problem is that the server doesn't send any certificate!!!!  so also having the right certificate loaded do not solve this problem.  (I know the problem is not the bat! but the server, but we have also to consider that for this problem a lot of the bat! users leave the bat to another client!......)

In my opinion to solve the problem (and It is a BIG PROBLEM, -just see the lot of post of this forum-)
the developer of the bat! have to add at the pop-up message an option like:


Are there here some developer that can add this feature at the next version of the bat! ???

Edited: Boss Boss - 26 October 2014 20:47:53
40839 wrote:
What don't you want anyone to ask you again? I didn't ask you anything. I was answering someone who needs help
Sorry Rick,  but have you read ALL my message??

"Do not ask me again" was reported to an option I would like the deevelopers add at the pop-up warning certificate message!!!!
Thanks for the help, people. However, two problems remain.

1) There doesn't seem any way to import a *.crt certificate file into the address book.

2) Without the certificate, TB won't let me PGP-encrypt emails.

Any further help would be really appreciated!
This question has been asked and answered several times over the years. There used to be a knowledge base article on the subject. Here is one thread:

The part you are interested in is:
"There is no need to change the configuration of The Bat! because the cause of problem is the loss of validity of the certificate fr om GlobalSign Root CA, which quite often occurs as a principal in the paths of certification. Certificate expired on 28/01/2014, but it's new.

1 Download the new certificate file (. Crt), available at
2 Open the address book in The Bat!
3 Choose a Trusted Root CA certificates
4 Search the database entry "GlobalSign Root CA" and open the entry
5 In the "Certificates" button "Remove" to remove the old certificate valid until 28.01.2014
6 Import the new certificate from the downloaded file. "

I followed this procedure and it does indeed correct the expired certificate problem. Don't forget to switch back to TB internal certificate processing.
In my experience you have to first get the certificates from the email provider or elsewh ere, then dig around a bit,in the settings and import everything in sight. I have vague memories of doing something advanced, then something easy, in order to get round the greyed out buttons.  Sorry I cannot be clearer.
Pages: 1