Pages: 1
The Bat 6.8.8 invalid Gmail certificate!
As of Jan 1 I'm getting a message that my Gmail server certificate is invalid. How can I fix this?


EDIT: by changing the date on my PC (win7) to Dec 30 2016 I've temp been able to get email but that obviously is not a proper fix and it limits browsing to some websites.

Any help would be appreciated.

2/1/17, 08:26:21: FETCH - Initiating TLS handshake
>2/1/17, 08:26:21: FETCH - Certificate S/N: 1FBEEDFD025A9B29, algorithm: RSA (2048 bits), issued from 15/12/16 1:34:00 pm to 9/3/17 1:34:00 pm, for 1 host(s):
>2/1/17, 08:26:21: FETCH - Owner: "US", "California", "Mountain View", "Google Inc", "".
>2/1/17, 08:26:21: FETCH - Issuer: "US", "Google Inc", "Google Internet Authority G2". Valid from 5/4/13 3:15:55 pm to 31/12/16 11:59:59 pm. This certificate has expired!
>2/1/17, 08:26:21: FETCH - Root: "US", "GeoTrust Inc.", "GeoTrust Global CA". Valid from 21/5/02 4:00:00 am to 21/5/22 4:00:00 am.
!2/1/17, 08:26:21: FETCH - TLS handshake failure. Invalid server certificate (This certificate has expired).
Edited: h bushell - 02 January 2017 16:00:37
Ok, after some more searching I've found a newer cert here.. which expires at the beginning of 2018 and installed it in the proper cert directory (intermediate certificates) but The Bat still gives me the same message about an expired cert. I tried deleting the older but identical google/geo trust cert but that made no difference.
Solved the problem. There is a setting in the bat, options>S/MIME and TLS, to use internally  stored certs or Windows certs. It was set to internal so I switched it  to Windows and now it's working. Never knew that was an option and it's  not well documented.
Very strange that this should now be an issue. I am using and had the same problem with the same certificate. Switched to "Microsoft CryptoAPI (Windows Certificate Store)" and finally am receiving emails again from my gmail accounts.

Anyway thanks for the tip.
Pages: 1