Pages: 1
RSS
Range Check Errors making TheBat almost impossible to use...
 
I have been using TheBat for a number of years (since ver 3, actually) A few weeks ago, I started getting lockups in TheBat with a lot of Range Check Errors. Anybody know anything about this??? Sometimes the proggy will restart, and restart and restart - I have uninstalled and reinstalled numerous times - I'm using TheBat Professional - 7.4.14 (32) and I'm just about to give up using the program at all...
 
I haven't heard of this problem before but that doesn't mean anything. Have you contacted Ritlabs' support about it (see menu above)?

With low-level errors like this, it's hard for a user to pin-point the cause. Some things that you could try (if you're so inclined):

- See if it still happens when Windows is running in Safe Mode.
- Run Process Monitor (freeware from Microsoft/Sysinternals) to see which files/reg entries are accessed just before the errors pop up.
- Compare The Bat's configuration to that of a month ago (from a backup)
- If The Bat still launches correctly some of the time, use its Maintenance Center to check the integrity of your message base.

Oh well, just some thoughts. I hope you'll get this solved!
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
Thanks for the suggestions....

What I finally did -

1. I ran everything through the maintenance center
2. Deleted all trash and junk mail
3. Restarted the computer and ran Maintenance center again.
4. Created a new backup.
5. Deleted TheBat from the computer, and deleted all leftover files as well.
6. Restarted the computer.
7. Re-installed thebat using version 7.0.0.56. (Wanted to get one before the 7.4 series)
8. Reinstalled Anti-spam Sniper
9. Restored backup.

Has been working well for the last few days. I had to reset all the "image allowances" as mail came in, but no big deal. (Not even sure this is a part of the latest Bat versions...)

Also, there was one BIG difference - I was previously unable to scroll within an email - I could, barely, but it was jerky, etc. I had to look at mail in a browser. It has been a real pain in the butt and more than once I went looking for a new mail client). My scrolling is now back to normal! No more browser (unless I just want to!)
 
Why do you use 7.4.14, but not the latest v7.4.16 which doesn't have any issues related to range check errors?
Pages: 1