Pages: 1
RSS
SSL support? Urgently needed!
 
My local ISP has changed their security setup and are now requiring SSL for email access. I have tried the settings they specified (changes to port addresses and authentication and security options. However, while I can download emails I have been completely unable to establish communication without SSL for *sending* emails. This is now a REQUIREMENT, and if I cannot find a way to make this happen with The Bat - and I've looked all over the help files and the forums for an answer - I will have to completely abandon The Bat and find a new email client, which is a real pain.

Any help appreciated!
 
Have you tried "Secure to dedicated port (TLS)" ?  

TLS is the successor to SSL and when Gmail began to require SSL, I had the same problem. It turned out though that The Bat's TLS worked fine with Gmail, both for sending and receiving mail. Hopefully it will work with your local ISP too.
 
Quote
Daniel van Rooijen wrote:
Have you tried "Secure to dedicated port (TLS)" ?  

TLS is the successor to SSL and when Gmail began to require SSL, I had the same problem. It turned out though that The Bat's TLS worked fine with Gmail, both for sending and receiving mail. Hopefully it will work with your local ISP too.
Yes. I attempted that, and also got new port settings fr om technical support at the ISP, and the server would throw error messages. The bad part is that The Bat is unknown enough that their tech support couldn't help me. In the meantime, in trying a couple of other email clients I now have a situation, as of about an hour ago, wh ere The Bat will not even OPEN! I tried updating yesterday to the latest version and was operating in trial mode (my paid version was the last one) and now the screen briefly flashes with the evaluation window and then disappears. I now have no access to my email at all.

This has become a very bad weekend.
 
The closing window immediately after starup is a known issue:   add /NOLOGO  to start param in desktop shortcut to fix that.

The server setting is possibly 'start TLS'  if 'TLS' doesn't work.  Good luck.
david
 
So maddening.

Finally got program to run again (thanks for the /NOLOGO tip... "known issue" is such a hilarious and evil phrase!). Receive mail fine but still impossible to SEND mail. Every combination of the outgoing settings have been tried. The latest sends back the following in the log:

1/27/2018, 14:34:12: SEND  - TLS handshake complete
1/27/2018, 14:34:12: SEND  - connected to SMTP server
1/27/2018, 14:34:12: SEND  - WARNING: there were no compatible authentication mechanisms detected
1/27/2018, 14:34:12: SEND  - sending message to (email address, which actually never occurs...)
!1/27/2018, 14:34:12: SEND  - Server reports error. The response is: 5.1.0 Authentication required.
1/27/2018, 14:34:12: SEND  - connection finished - 0 message(s) sent
1/27/2018, 14:34:12: SEND  - Some messages were not sent - check the log for details
 
The "5.1.0 authentication required"  is a generic message and usually means the id and password provided are incorrect. The SMTP server requires authentication and checking the id and password would be my suggestion to check. Good luck.
 
Quote
david kirk wrote:
The "5.1.0 authentication required"  is a generic message and usually means the id and password provided are incorrect. The SMTP server requires authentication and checking the id and password would be my suggestion to check. Good luck.
David, thanks for the 'translation' of the generic error code - that helps! This must be a long-standing issue with my ISP, id and password *are* correct and it shouldn't be throwing an error. I'm going to have to spend time on the phone tomorrow with them before throwing in the towel. Thanks for your assistance!
 
Well, The Bat just lost a customer. It was good for about a year, but I can't get the ISP to change so I have to change clients and now I've done so.
 
I can confirm that The Bat! is relying in pretty old cipher settings for SSL/TLS. When I turn on the option

ssl_cipher_list = DHE-RSA-AES256-SHA:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!CBC:!PSK:!SRP:!DSS:!SSLv2:!RC4

on my dovecot IMAP Server, The Bat! is not able to connect/authenticate any more. Would be cool if the SSL/TLS stack could be upgraded to newer versions/stronger crypto so that I can turn on that sane settings again.
Pages: 1