Pages: Prev. 1 2 3 Next
The Bat! v8.3 64-bit repeatedly crashes., How to revert to The Bat! v8.2.4 64-bit
Thomas Dahl wrote:
The problem continues..  On 6 computers at my company.  Frustrated users complaining to me almost daily...
Why don't you open a topic about it and provide more information?
Do you get any error messages? Do the crashes also happen when running Windows in Safe Mode? Or when running TB! as Admin? What separates those 6 computers from the others? What is TB! doing when it crashes - have you tried running Process Monitor to find out? Do the logs show anything?
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Hallo Daniel,

I have a thread going with RitLabs on in their ticketing system where I have posted very many screen shots and carried out many tests and trials on their behalf.  This has been going on since version 8.0.10 in November of last year.  They keep saying that they have fixed the problem but they have not.  I have offered TeamViewer access etc etc.

Before this version TB worked BEAUTIFULLY.

I do not know of another program or service we have introduced since November that could be causing a conflict with TB.

I have one user who gets 2 hours of use out of TB before it crashes.  This means it crashes pretty much reliably 6 times per day.  Myself it crashes about twice a day.  Other users have the problem somewhere in between.

It is now May 2018.  

My problem is that I am too heavily invested in TB.  It is an excellent program in so many ways.  I have a large filtering system and hundreds of sub folders.  To change to another program will take a MASSIVE amount of work cost me thousands of Euros in lost productivity.  I love TB, but not this bug.  I have used TB for a very very long time, I think since rev. 1

I just want them to fix it !!

In answer to your question:
  • This seems to be the same topic as the OP
  • I have tried Safe Mode and it still crashes
  • Nothing separates my 6 users as they all have crashes
  • I have not tried the Process Monitor..  I will try this.  I do known that some crashes leaves TB in a state where it is still an open process, but appears to be shut down in windows.  This requires to go into the Task Managers to manually close it
I really really hope that someday this will all be sorted so that I can stop loosing productivity and having to keep passifying my employees that it will be fixed soon.

I am only really taking to the Forum as RitLabs do not appear to know how to resolve this and I need a solution or at a minimum a plan.  I am here in the hope that someone else can help me.

I am happy to PAY to have this fixed.

I may have missed it in this thread, but what result did you experience in going back to a prior version? Since you're hitting a wall in getting version 8.x resolved, reverting to a prior version may be a less painful path (?) I wouldn't attempt without doing a full backup, but it may be easier to get that approach working.
I am in the same board as Thomas above.  I am running Win 7, 64-bit system.  I have TB7.2.X running for over a year plus with zero issues.  One day I get a popup in February this year to upgrade and that's when the issues started.  I have an open thread with them and when I got a crash this a.m., they seem to have closed the thread and I had to start a new one.  
I tried reverting back to a 7 version, but it won't happen. So this a.m. I asked for complete uninstall options, so I can reinstall with a 7 version.  Sorry, but I can't pay for something that doesn't work.  
Same problem here :-/ Please provide a fix asap! Thanks.
Thomas: I agree with David Kirk that going back to v7 seems like an obvious work-around. The Bat v8 introduced some new processor and memory optimisations, so a bug in those might be responsible for the crashes. However, another option would be to try running the 32b version of The Bat and see if that runs more reliably (also seeing that all reports seem to be from 64b users). You could also try running the program in Windows 7 or even Windows XP compatibility mode (through the properties of your TB desktop shortcut). Personally, I would try these possible solutions before reverting to v7.

Yes, Process Monitor might help you figure out what The Bat was doing just before it crashed. I have a feeling that it will be difficult to pin-point the cause of these crashes though. I can think of a few more things that you could try, but they're not very likely to yield useful information (at best, they might help the developers to consider or exclude some possibilities). For instance, you could let The Bat run overnight while the PC is disconnected from the internet. When you return the next morning and the program has still crashed, the problem won't be related to browsing, viewing, retrieving, filtering/processing mail.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
This approach may not work in restoring a version 7, but may be worth a try. My registry backup utility at  has documentation on doing a fulll restore with saved registry. It doesn't explain how to remove TB!, but my thought would be to rename the directory where TB! resides and delete the registry entry (after exporting with my utility), make a copy of the mail folder, and then following the provided restore instructions, copying the mail folder to the new location. This little utility isn't a magic bullet, but several have told me they were able to restore successfully with it. If you have the exe for a version 7, it may be worth a try. And by renaming the registry where version 8.x is installed, you shouldn't lose anything. Good luck,
Found a fix. The May Windows 10 update is when my crashes and The Bat refusing to connect to POP3 started. I uninstalled update. All better now.
My users have had the very regular program crashes since the end of 2017.  The May 2018 update of windows has not changed anything..

Going back to windows 7 would mean a VERY major upheaval in our company.  Many laptops we have do not have drivery for windows 7 anymore so these will have to be replaced etc etc.

I just wish Ritlabs would just get on and fix the problem  My users are becoming very frustrated and are asking if I can find an alternative product for them.
Edited: Thomas Dahl - 30 May 2018 12:52:31

Out of pure curiosity, I did an install of 7.4.16 and imported a backup created with 8.3. No problems. All my accounts ae IMAP, for whatever that's worth. I do not understand why you do not just do that? I don't know if the problem is also in 7.4.16, but from your posts I infer that it is not. This seems such an easy solution that there must be some reason that you may not have shared. There are undoubtedly features that you would not have that are in 8.3, but you would have a working system. Please share info on why reverting backwards isn't workable, as that may generate more ideas. Good luck,
David, you are right.  I should try to go back to 7.4.16 which is a 15 month old release.

I am just a bit reluctant to to have to do this as I have no idea what else could break.  It also seems rather counter-productive to go backwards.  Some of the changes in the versions from this year will be lost that I have gotten used to.

I will also need to go to each user and make 2 back-ups.  Try a reinstall and try it.  My personal email folder for TB is 222Gb  Backing up all of these files twice will take days...

Why cannot Ritlabs just make the effort to fix this..?
I agree that Ritlabs should fix it, but you're running TB! in production; your business depends on it. For that reason alone, I would stop thinking of TB! as an email client, but as a production engine. To stabilize your business, I suggest doing as I suggest to other companies: go back to a release that is stable, in this case 7.4.16. When the next upgrade comes out (such as 8.4), do not upgrade to it, but wait 1-2 months for it to stabilize and then upgrade one PC and run it for a few weeks. If all is well, then upgrade the other PCs. Forbid/prevent any of your staff from doing any upgrades on their own, as what you want is the same platform on all PCs. That gives you a buffer against a version that is unstable for your environment. And if you run other products on your PCs, I suggest a similar strategy to minimize conflicts. I agree that you won't have the most recent bells and whistles, but you'll have stability.

My other concern is whether Ritlabs is having trouble maintaining the product. There was/is the NOLOGO mess that hampered users for months and also the TLS1.2 protocol has been out for 10 years, yet still not in TB!. I'm not well versed in telecommunications issues, but from what I've read, the lack of TLS1.2 support, could prevent email access if the host requires it. Is your email on your PC, or a server that is backed up daily? 220gig is a lot mail. I wish you the best in resolving this. Going back may seem a step backward, but for your business stability, it may well be a step forward. And that will give you time to revisit TB!'s role in your business.  

Good luck,

Edited: david kirk - 01 June 2018 21:52:28
I am having similar problems getting The Bat! to run on a new computer running Win 10 1709. Now I know why Rit Labs has not replied to my ticket—they don't know how to solve the problem.
I tried a different version, but only went back to 8.2.8. I guess I have to go back farther. My wife is running The Bat! on the same model of Dell laptop and much of the same software without problems.

I have been restoring a backup of my C: drive after each failure. (Well, before that, I tried clearing out references to The Bat! in the registry. Didn't solve it either.)

Can anyone tell me or refer me to instructions on how to look for info in the Events log? Would that even help, or should I just try the last update to version 7?

ADDENDUM: 02 June 2018

I no longer need help looking in the Events log, because Daniel's /nologo trick solved my problem:
Edited: chileverde - 02 June 2018 19:37:52 (Update post)
Just wondering if users who have this problem (64b version crashes, not fixed by /nologo) have tried any of the following..:

- Run The Bat in Windows 7 or Windows XP compatibility mode (rightclick on shortcut, then Properties | Compatibility)
- Use the 32-bit version of The Bat (will still be pretty fast, but avoids possibly buggy 64b optimisations)
- Disable Windows Data Execution Prevention for The Bat (MS explanation)

(note: just to be sure, I would still use the /nologo commandline parameter when doing these tests).

The Process Monitor tool (free download from Microsoft SysInternals) may be able to help you pinpoint what The Bat was doing when it crashed.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Are you using the AntiSpamSniper with The Bat!? If yes, try to disable it to see if it makes any difference.
Vilmos Kertesz wrote:
 Ray Mitchell  wrote:
I'm using Win10 64 with the latest updates and running 3 simultaneous instances of TheBat!
I am just curious. Why are you running 3 instances of TB! ?
(I am using TB from '99 or so, and still using Voyager 4.xx on my laptop, so I lost a couple years of later development...)

One for my personal email, one for my school email, and one for my application development email.  I don't want any of these mixed together and sometimes I don't want to access all of them.  It's just a convenient way for me to organize them and get a separate notification banner for each..
Gonzo Far wrote:
Okay - finally got a reply from support on this:
Please try to sign into your Google account and in the "Privacy\Sign-in  & security\Apps with account access" section remove "The Bat! v7"  from the list of applications. Then try to receive mail in The Bat! and  allow the access.
I've looked all over my Google account for something called the "Privacy\Sign-in  & security\Apps with account access" section and have found nothing.  Can someone please provide me the step-by-step clicks for reaching it?

Also, this problem with multiple requests from Gmail to "Allow" or "Deny" then finally ending in TheBat! hanging up or crashing is really getting me down.  Has anyone found another email client with the features of the TheBat! that actually works correctly?  Back a few years ago when I was searching TheBat! was the only one I found that would meet my needs
I've looked all over my Google account for something called the "Privacy\Sign-in  & security\Apps with account access" section and have found nothing.  Can someone please provide me the step-by-step clicks for reaching it?

Go to
Click on "Sign-in & security"
Click on "Apps with account access"
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Daniel van Rooijen wrote:
I've looked all over my Google account for something called the "Privacy\Sign-in  & security\Apps with account access" section and have found nothing.  Can someone please provide me the step-by-step clicks for reaching it?

Go to
Click on "Sign-in & security"
Click on "Apps with account access"
Yup!  That's it.  I was trying to find it fr om some link on my inbox or other mailbox page.  Then by accident and in addition to the link you provided above I also found that simply clicking the big round button with the single letter in it in the upper right of the window would get me wh ere I wanted to be too.  And the best thing is that deleting the reference to TheBat! v7 in all of my gmail accounts fixed the problems I've been having with the newer versions of TheBat!  Thanks
Just a quick update..  The crashing goes on..

I have not tried going back to version 7 of TB.  I simply have not had the time.  I know someone will reply and say the lost productivity in version 8 is costing me more than the time to try this fix.

I still keep hoping that Ritlabs will fix this.

I guess in the back of my mind I keep thinking that if going backwards to a previous version is such a "negative" things to have to do that probably I am better off looking for a new product that "just works".  

I have a similar love-hate relationship with windows.  I dislike windows 10 a lot, but I would not go back to windows 7.

Can someone recommend a better email client that has similar features to TB?  I particularly like the ability to sort my emails into folder and virtual folder.
Hi, Thomas,
Going back isn't a good option because of security updates for TLS in 8.x. As more sites start enforcing TLS 1.2 you would find yourself in a box. You've been hoping RITLABs will find a fix, but it hasn't happened. Maybe it's time to make a decision and move. If you use IMAP, a switch might go fairly quickly. Choices I see are:

- Postbox. It was built on Thunderbird, but has more and more of new code. There is a one-time fee (approx $28 as I write this), but it works and there is active support
- Thunderbird. Somewhere in the past it got a bad rep, but it has grown significantly in feature and support in past years. I recall reading many articles a few years ago, saying it was dead, but it has done just the opposite. And there are many addons to extend its features. It probably doesn't do everything you want, but it works. I use it on occasion when I get frustrated with TB!.

- Outlook. I've stayed away from Outlook, but many swear by it.  

If none of those are acceptable, then you're left hoping for a fix that may never come. There are a few other clients, but for a business you will want one that has a large base of users. Good luck in your pursuits.  

Reading the prior posts I may have missed it yet will ask this question: Have you tried the 32 bit version instead of 64 bit?
There may not be much difference unless your mailstore is huge. Currently I have little over 15GB total contained within 148 or so folders and The Bat (including Voyage) stable.  

I do understand I may not be stressing the application in the same manner, just a thought.
Arnold DeRoy wrote:
Reading the prior posts I may have missed it yet will ask this question: Have you tried the 32 bit version instead of 64 bit?

I suggested that twice and if Thomas is interested in solving this problem he should definitely try that. Other possible remedies would be to disable Windows' DEP (data execution prevention) for The Bat, and running The Bat in Win XP or 7 compatibility mode (easy to turn on/off through the shortcut's properties). Checking Options | Preferences | Plugins to see if they have any old buggy plug-ins running is worth a shot, too. And if all six computers affected are identical, I'd check to see if the manufacturer has driver updates are available.

Chances are that this is not a bug in The Bat (or many more people would be complaining here). My hunch is that The Bat, on Thomas' systems anyway, is triggering an obscure problem in the security features of Windows 10.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
OK, 32bit was tried, sorry wasted bandwidth.
Virus scanner? I had to stop using one companies scanner since it caused my tape backup software to fail. Removed and replaced with another well known German scanner and the fails/crashes stopped.
Thank you guys!  

I will do some more research.  Just one question.  Which virus scanner was causing the problem?
Pages: Prev. 1 2 3 Next