Pages: 1
Bluehost: FETCH - TLS handshake failure. The server host name does not match the certificate.

I just set up an account with Bluehost and configured TB to fetch emails from it via POP3 SSL according to the settings on the Bluehost website.  The problem is that I get the error, "FETCH - TLS handshake failure. The server host name ... does not match the certificate.".  Upon reading their website I found the following concerning certificate name mismatches:

If your email application is set up using Private (with SSL) settings, and you're using your domain name as the mail server (such as, your email application expects the SSL certificate to contain your domain name, when it contains the name of the Bluehost server (such as instead. Because of this mismatch, your email application will warn you that the name on the Bluehost server's certificate doesn't match your domain name. This is normal.

Email applications will allow you to continue to send and receive mail, but you may need to adjust a setting in your email application to confirm you're aware of this configuration. Each email application has slightly different steps for setup. If you aren't sure which setting to change, check out our Email Application Setup Guides.

Since Bluehost and many other email providers do use each account's name as the mail server name such a mismatch error always occurs if the certificate is installed, and TB apparently doesn't offer the option to "always trust" (does it?).  The only other choices seem to be not to install the certificate at all and always have to click the "Continue anyway" popup window that opens each time TB checks for email, or to not use SSL at all.  Many email clients do offer an "always trust" option and it would be convenient if TB did too.

Any suggestions or workarounds would be appreciated.

Edited: Ray Mitchell - 10 April 2019 11:18:08
I found a workaround.  It turns out that Bluehost does provide several SSL servers in the domain that are mapped to by the various account domain names.  Since the mapping is account dependent you have to contact their support to get the appropriate "box" server name for your particular account.  When I used that name everything started working perfectly.  It would have been nice if that had been documented somewhere to save all the frustration but at least it all ended well :-)
Pages: 1