Pages: 1
The Bat! - my installation is now taking a long time to close
A couple of months ago, The Bat started to have a slow shutdown om my PC. Instead of a second or two display of compacting folders (ssd made this very quick), there has been a 45+ second delay, where the program is completely unresponsive, with the mouse cursor becoming a circle, before the folder compacting screen appears and it shuts down. Only The Bat is unresponsive, everything else is ok and my PC is not locked up.

If, during use of The Bat, I go in to the Preferences screen, the same delay occurs in making any change to any setting there. Oddly, once one change is made, any subsequent changes in the same session are immediate. Even more oddly, The Bat then shuts down completely normally until the next time it is opened, when it's back to slow shutdowns again.

Things I've tried:

1. Going through all the preferences settings to make sure paths etc. are valid.

2. Deleting as much old mail as possible in case something has got corrupted.

3. Folder maintenance - no issues found.

4. Complete uninstall via the Changes option to remove all folders, then restored from back-up. Problem remains.

5. Chkdsk for corrupted files - no problem.

Anything else I can try?


The Bat! Professional v8.8.2, 64bit on Windows 7, POP3 only (no IMAP)
Could it be trying to access a (slow) network resource, or a path on a drive that's asleep?
Maybe you could try running Process Monitor (freeware by Microsoft Sysinternals) to find out what The Bat is doing that takes so much time.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Thanks, but no - all the Bat's files are on C: which is an SSD.

I've checked all paths in Preferences and Account options and can't find anything leading elsewhere. All drives are active and ok.
I ran process monitor and there were thousands of error messages for thebat64.exe on shutdown. File locks, all kinds of stuff. If I made an preferences edit before shutting down, i.e. temporarily giving a normal shutdown time, I only got the following error about 30 times:

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Time Zones\GMT Standard Time\Dynamic DST  NAME NOT FOUND

It's not finding that registry value because the Dynamic DST key does not exist on my PC.

I did a complete re-install only this time I did not enable on-the-fly encryption as the above pointed to a range of file access issues. This seems to have fixed it. There still is a small delay of about 3 seconds before the compacting screen pops up; process monitor shows the above DST registry error well over a hundred times, which may account for it. It's also giving a name not found several times for this key:


CTF is there in the Registry but not KnownClasses

Thanks again

Edited: Rezillo - 13 April 2019 18:24:17
delete CONFIG.CDB and try again, helped for me when the bat took minutes to close and open!
Pages: 1