Pages: 1
Drag&drop and SendTo failure with Windows10
Hi all, first of all, sorry for my english.

I just installed Windows 10 64-bit (clean installation) and when i began to use TheBat v6 i had the following problems:

- I can't drag&drop files from Windows to TheBat, for example to attach a file. But in the other way (from TheBat to Windows) it works normally.

- "Send to" doesn't work, neither for mail recipient, nor fot TheBat direct link

Both worked with Windows 7 and XP. I checked file associations (.eml .msg .vcf) and everything is OK, and TheBat is defined as default mail app.

Thinking of an incompatibility with my old version, i just purchased update to v9.3.2 (64-bit), but the problems are the same. I opened a ticket in Ritlabs Support, but  i have no response.

Thanks in advance for your help
Edited: Boris Grushenko - 22 January 2021 13:13:56
To start with the Send-to problem: When you installed The Bat and configured it, did you have full Administrator rights in Windows?

In Options | Preferences | Applications, you can (again) make The Bat the default MAPI handler and associate it with all email-related filetypes.

If that does not work, I would suspect that maybe an antivirus/antimalware program may be blocking the Mail-to function.

For the drag & drop problem, I wonder if it would help if you put /NOLOGO on the command line. You can do this in the properties of the shortcut (icon) that you use to launch The Bat - you can edit the command line there and put a space and /nologo behind it, like this:

"C:\Program Files\The Bat!\thebat64.exe" /nologo

Hopefully the support folks will still respond to you, too - it sometimes takes a few days.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Thanks for your answer.

Yes, i have full admin rights. I changed manually all associations, and defined TheBat as default program for mail, and didn't work. Also, i deactivated antivirus and firewall and nothing happens. I receive allways the following message (acceso denegado = denied acces):

[Broken image removed - DvR]

And about drag&drop, it works dropping on app icon (even without adding /nologo). The problem is with opened messages. To attach a file, i used to drop it directly on the editor window, and now this doesn't work
I can't paste image, the text is:

"Application Error

Exception EOSErrorW in module thebat32.exe at 00294599.
System Error. Code: 5. Message: Aceso denegado. Location:
ConnectToRemoteServerPipe; OpenPipeForWriting before

¿ thebat32.exe ?  :o  
SendTo is solved. I installed TheBat v9 in same folder than v6, and the 32 bit exe was still there (and the installation didn't changed SendTo link)

But Drag&Drop didn't fixed
It sounds like you have tried everything, but it is strange that no-one else has reported any of these problems. That would suggest that there's still something on your end that causes the problem, but what..? Hopefully the Support people will respond soon, maybe they have dealt with similar reports before. Maybe you can go back to your support ticket and add a link to this topic, so they know about the things that you've already tried.

EDIT: Good to hear that the Send-to part was fixed!
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
About the drag and drop.. Have you tried this? Instead of dropping a file directly onto the message editor..:

- Click and hold the left mouse button to pick up the file that you want to attach
- Still pressing that button, drag the mouse pointer to the taskbar and let it hover over the box that belongs to the open editor window
- The editor window should now come to the foreground
- Now drop the file into the editor window.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
I just tested it and it almost works, but not completely.

Dropping it opens a new editor window, so the result is the same as dropping the file on the application icon.

It's better than nothing, and certainly more comfortable than attaching it from the message editor, looking for the file.

Thank you very much, following your advice I will send the link to this post to Ritlabs support
SOLVED !!   :)  

After a time looking for a solutions, i founded that the problem is running TheBat! as administrator.

I don't know why, but if you run as administrator, the drag'n'drop stop working. Thanks for the help

The bad news is that now TheBat! is extremely slow on exit. After a long time with the message "compressing trash" (in spanish, something like that), i get a message "file could not be opened D:MAIL\ADDRBOOK.INI. Access denied" ... of course that file exists in the specified folder, and i can open without problems with notepad.

Maybe that's the reason i changed to admin mode, i don't remember  :(  
Edited: Boris Grushenko - 03 February 2021 19:07:29
Hello boris.

I have the same problem , but with the version 5.0.36.
And when i close the app, thebat is extremely slow on exit.
Pages: 1