Pages: 1
Cursor icon shown a few characters ahead of where it really is in 9.45
For me the Halloween Edition (v. 9.4.5), was definitely a trick, not a treat.

When I compose mail, the cursor appears on the screen a few positions ahead (to the right) of where it really is. I have only installed v. 9.4.5 on one of my family's computers, as I did not want the others to suffer this problem. OTOH since I don't see any posts about this, maybe I'm the only one with this problem. Do you have other reports?

The problem does not occur consistently. It happens most of the time since I upgraded to 9.4.5. Sometimes it is happening as I start to compose a message, and then the position changes to the correct position.

Example: suppose I misspelled a word...


In this example I typed "u" instead of "i". So I place the cursor to the right of the u:


Now I hit backspace, but instead of deleting the "u", The Bat! deletes the character a few positions to the left, such as the "o" in this example:


Does anyone else experience this problem?

Here is an example of how the problem changes within an email. I am replying to a message from a friend. In the reply window, his message to me includes this quote:

I’ll see you on the  29th at  Joe's.

Note that there is an extra space after "the". The extra space was not included when I copied from The Bat! and pasted into Firefox, so I added it, so you can see how this appears in The Bat!. If I place the cursor after the "u" in "you" and hit backspace, it deletes the "o", not the "u". But if I place the cursor after the "t" in "at", it functions correctly and deletes the "t". I have opened three reply windows for this email, and they all have this feature—the extra space, before which the cursor is misplaced.
Edited: chileverde - 14 November 2021 22:43:20 (mistyped word)
I just upgraded yesterday and I have not noticed that problem.  

That sounds quite annoying, but you're the first to report this problem here. Are your video and mouse drivers up to date and are you using any utilities that may interfere with the mouse pointer or the text cursor, such as screen capture software, desktop/monitor tools, etc? Those are two areas where I'd look, unless more reports come in.

Are you editing in text or html mode?
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Thanks for the replies. I am editing in HTML mode. I can't speak for mouse drivers, but I just updated the Intel HD graphics driver, and it did not solve the problem. Macro Express can affect keyboard entries, so I tried turning it off. Can't think of other possible causes. As for mouse drivers, I update when I get notices to, so those are probably up-to-date, and I don't think they would explain a difference in behavior between 9.4.4 and 9.4.5.

Here are my experiments since my OP above:

(1) I have previously seen occasional funky behavior with the Constantia font, which is my default font. For example, sometimes when I would type the letter È in The Bat!, the grave accent would not appear. But it would appear with other fonts. I checked out a sans serif font, Tahoma, and another serif font, Georgia. The problem did not occur with either one. Too bad I like the look of Constantia!

This is really interesting: when I typed in Constantia into a new message window, at first, the cursor would appear exactly where it should be—just to the right of the right edge of the last character typed. As I continued to type, the distance between the right edge of the last character and the cursor would gradually increase, until, around two-third of the way across the screen, the distance was equal to the average width of a character. In this area, I could place the cursor next to a character, press backspace, and see that it would delete the character located one character to the left of the character next to the cursor. This only happened in The Bat! In MS Word, the cursor appeared where it should.

(2) I tried to uninstall Constantia so I could reinstall it. Windows would not let me delete it, because it is a system font, actually a family of four fonts. I went through the motions of reinstalling each Constantia font "over" the installed font; I don't knot if this made any difference. In any case, it did not solve the problem.

(3) I uninstalled v. 9.4.5, restarted my computer, and reinstalled the same version. (I did not download it again; guess I should have.) Nothing changed.

(4) I uninstalled v. 9.4.5., restarted my computer, and installed the previous version,  v.9.4.4. Problem solved.

That suggests to me that something changed between the two versions that affects the Constantia font and perhaps some other fonts, but not all fonts.

If a few of you who also use The Bat! 64-bit v. 9.4.5 could try typing a few lines in Constantia, I would appreciate it. If you can reproduce my problem, it might be worth it for the developers to look into it.
Actually, now that you've pinpointed it to a specific font and a specific version of TB, I think you would do well to report it to the developers right away. Good sleuthing!

ps: Would this be related?
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
I opened a ticket. Tech support was unable to reproduce the problem.

My system works great now that I downgraded to v. 9.4.4.

To minimize spending unnecessary time on this, I am not upgrading other family members to 9.4.5, I'll just wait for the next version and give that a try.
Pages: 1