Pages: 1
"Waiting for dispatcher..." - what's that?
For several the Bat!'s updates I often see Waiting for dispatcher status message in the Connection Centre.

It begun (I think) since the Bat! v3.

I have 6 accounts, I check them all at once (by Alt-F2).
Once every ~20~30 attempts I see that 5 accounts got served completely while one (not always the same) has got stuck. The Connection Centre may sit waiting indefinately - I always loose patience first...
I have to Abort all to close the Connection Centre.

Today this has happened to the Bat! v3.95.06
I wonder what may cause this?

By the way - some recent version had another peculiar defect: after I moved a message from one folder to another - a Moving messages... was sitting stuck in the Taskbar.
winXP-SP3 Pro, the Bat! v4.0.38
Confirmed here. THe Connection center regularly "hangs" and I must abort all
that's a leftover bug from 3.95.02 (it hung EVERY time for me, but 3.95.03 corrected it completely)

I think Im NOT going to update to 3.95.06 - too many bugs reported for it!!! i will wait for 3.95.07  :|

(actually i'm leaning towards DITCHING TheBat for 2007)
No, I've seen this [mis]behaviour since the very first v3 releases...
It's not a v3.95.02-introduced bug.
winXP-SP3 Pro, the Bat! v4.0.38
It's back!

Reviving an old posts from many years ago, I now see the dreaded "Waiting for dispatcher" problem.  After working correctly for several months The Bat version 9.1.18 (32-bit) suddenly started issuing the “Waiting for Dispatcher” message in the connection center when I try to “Dispatch mail on server” and when I attempt to “Get new mail.”  No changes have been made to The Bat configuration or to Windows (7 SP1).

The “Waiting for Dispatcher” message remains on the screen for several minutes before timing out and giving up.  The issue occurs every time I use The Bat, thus rendering the program useless.

I have tried The Bat version 9.4.4 (64-bit) with exactly the same result.

Any help with this issue would be appreciated.

Paul Brockman wrote:
No changes have been made to The Bat configuration or to Windows (7 SP1).

As mysterious as this problem may be, something must have changed somewhere (computers never do anything spontaneously).

Is the connection center always waiting for one particular mailserver (account) to respond? Has anything in your antivirus/firewall changed?
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Hi Daniel,

Thanks for responding.  The problem occurs with both of my accounts (with the same ISP).  Both antivirus and firewall are explicitly switched off.  I am able to send messages but not receive.

I can assure you that the receive mail server/port number/password/authentication, etc, have not been changed (I have double checked).  I was happily using The Bat! for receiving emails, then left the computer for a while to do other things.  When I returned, the problem was extant.  Nobody else has access to my computer.  Microsoft did not appear to force an update while I was away.

I have tried uninstalling and re-installing The Bat! (various versions), but the problem remains with all of them.  Both Pegasus Mail and OEclassic are able to send and receive emails at this time.

It's a riddle wrapped in a mystery inside an enigma...

But, something may still have changed on your provider's end. In the Options dialog of your Account Properties, you can turn 'Verbose logging' on. And in that same window, under Transport | Protocol Logging, you can turn logging on for the mail retrieval protocol (pop3). Then you can give it another try, and check those log files to see if they contain any more specific clues as to what is going on.

(Note: this is true for pop3 accounts, I don't know about IMAP, which has a very different Account Properties window..)

If this doesn't help either, I suggest that you submit it to Ritlabs' Tech Support. They should know which conditions may trigger that error message.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Hi Daniel,

Yes, it's a puzzle.  I tried again today to "dispatch mail on server."  The Bat! responded correctly for one of my accounts but not the other.  Tried a few minutes later and the problem was back on both accounts.  Something seems to be working right on the hairy edge.  Sometimes it flops one way and sometimes the other.  A timng issue, perhaps.

I  use pop3 so I will try your suggestion regarding the logs.

Thanks again for your help.

Pages: 1