Pages: Prev. 1 2
RSS
Unknown CA certificate, How to disable the "Unknown CA certificate window"
 
I have the same problem after installing vista and importing backup data!
 
Quote
wadpro writes:
I have the same problem after installing vista and importing backup data!

Same here, and I'm pretty sure this is a bug. I switched computers (to Vista too) and after I did a fresh install I didn't get any error messages. But then I restored my backup... And while I'm still using exactly the same account information now I do get the "unknown CA certificate" dialog.  
 
Not a bug but definitely a nuisance! I had this problem when checking Gmail accounts. Resolved it as folows:

1. Check POP access is enabled for the Gmail user from Gmail controls (obvious but can be overlooked!).

2. Setup the Gmail account in the bat! using TLS on port 995.

3. When FETCH fails look to see the name of the issuer of the root certificate (currently Equifax Secure Certificate Authority).

4. Download the relevant certificate to hard disk:
https://www.geotrust.com/resources/root_certificates/certificates/Equifax_Secure_­Certificate_Authority.cer

5. Import the certificate into the Gmail account using the Edit personal Certificates button on the General page of the Properties dialog.

6. View the certificate and Add to Trusted on the Certification Path page.

All done! :D  
 
Thanks Stewart, that solved the problem (at least for me) :D
I still don't understand why it happened only after I restored my backup, but to be honest I don't really care about it now that it's working again.
Thanks again!
 
Hey stewart you are a genius! You are my man!
I had stopped using The Bat because of this certicate error. After using your method the problem has been fixed. Many thx! I hope, we wont need to download this certificate to fix this problem on the newer version of The Bat.
 
Another (easiest) method :

- close TheBat

- open your TheBat home directory (usually C:\Documents And Settings\<your_Windows_loginname>\Application Data\The Bat!)

- delete the files
RootCA.ABD
IntermCA.ABD
tbuser.DEF

- start TheBat.

The missing file will automatically be created again.
no certificate need.

worked for me.
 
LaurentCliff's fix works - good one!

(I had the problem and was using Windows 8)
 
The only thing to be aware: deleting tbuser.def will reset all your customizations. It would be interesting to test whether or not you need to delete that file

If you have no customizations (shortcuts, toolbars etc) then it is no problem. I have several that would be a pain to recreate  :D
 
I had the same problem with a SSL secured IMAP account.
TheBat logs told me that my virus scanner failed on verifying the certificate (see below). So I decided to turn off virus check of e-mails sent through SSL. This solved the problem of TheBat's annoying pop-up.
Perhaps somebody may profit from this info.
Code
>14.04.2013, 00:51:36: IMAP  - Issuer: generated by avast! antivirus for SSL scanning, avast! Mail Scanner, avast! Mail Scanner Root.
!14.04.2013, 00:51:36: IMAP  - TLS handshake failure. Invalid server certificate (The issuer of this certificate chain was not found).
14.04.2013, 00:52:46: IMAP  - TLS handshake complete
 
OMG I used to click on [OK] button for years, every 3 minutes!
It's all about getting certificate from a website of Issuer which is mentioned in the logs of your current hosting and install it to a new certificate contact (any name, and details).
 
Just add the correct 'AddTrust External CA Root' certificate.

Here is the link to download AddTrust External CA Root - UTN SGC.
Install this certificate and problem would be solved.
 
Hi,

I just ran into this problem. I was able to solve half of the problem using Stuart's method. I don't get this error message, when I CONNECT to IMAP server, but it still pops up upon SENDING.
Any help appreciated!

Thanks: Balazs
 
Hello,
got this message
!15/07/2015, 18:51:59: FETCH - TLS handshake failure. Unsupported certificate
Gmail POP3 account
How to fix it?
TB! 4.0.24 version

Thank in advance
 
Hi,

you are not alone, same Problems here. GMX and other Provider works well with TLS, only Gmail sucks. Should be a problem by gmail.
 
Should be solved today by google mail Service
 
Peter Schoutz: Its strange, I have never this problem but from 18.07.2015 I have this problem!

If I have delete

RootCA.ABD
IntermCA.ABD
tbuser.DEF

still annoying pop up window.

Please help.
 
If you get the "Unsupported Certificate"-error with Gmail accounts:

There is another topic on that subject (see here). It occurs only with The_Bat versions older than v4.0.38. You can ask Ritlabs' support (see menu above) for which versions your license is valid. If that includes v4.0.38, you can upgrade to that for free and that will solve the problem.
 
Bumping this thread, this may sound stupid but how do you actually obtain the certificate that you need when you get this certificate mismatch error?  It's driving me buggy, I can't connect to 2 account via IMAP that our organization uses (hosted on GoDaddy) and GD support has no clue what I'm asking for
 
re-bumping...Can someone translate the steps for obtaining the CA Certificate, root certificate, intermediate certificate, etc, and what does "CA" actualy mean?

I am really completely unfamiliar with any of this, all I know is that I can add an exception with every other client SW except TB...
 
For solution, see post #3 (Jan Smoller):

https://www.ritlabs.com/en/forums/forum4/topic11441/
 
I fixed this by changing my DNS. I was using these 91.239.100.100 and 89.233.43.71  I switched them (a few different ones) and it worked.  Laurentcliff's solution about deleting the files mentioned above did not work. It actually messed up my configuration (good thing I backed them up instead of deleting them - this is NOT a proper way to fix problems!) I did not try the other solution by Stewart Edgell. My problem was a bit intermittant, so I assume it might have been due to time delays with the DNS?  
Edited: steve ripple - 18 August 2017 20:28:44 (fixed typos and added more details)
Pages: Prev. 1 2