Pages: 1
RSS
Cannot download images in personal HTML signature
 
Hi guys,

I need your help because it seems like that in the latest The Bat! version the Image Download Manager no longer exists. Before we had:

"You can also configure the download of embedded images from external sites choosing one of the options – never, always or reject unknown. To specify these settings click Configure – The Image Download Manager window will open."

This affect the correct display of my HTML signature as the images expected to be in the signature are no longer donwloaded. Is there a way to fix or bypass it?

I don't know if I'm doing it correctly when it comes to insert the HTML signature but I use the "Macos --> Include a Template file" option selecting an HTML file. Is this the right way?

Thank you a lot!
 
I'm not sure if I understand your question correctly.  Why do you believe that the missing download manager is keeping you from linking to an image in your outgoing messages? The download manager dealt with incoming messages, not with outgoing messages. And if you configure The Bat to retrieve images, it should allow you to view all images in incoming messages.

Side-note: Wouldn't you rather add your signature as an attachment? This is much easier and that way, it will also be visible to people who, for good reasons, block the downloading of external images (external images can be used to see if people have received and opened a message and it will give away their IP and other information).

Anyway, as far as I know, the only way to include actual HTML source code is by inserting a specially prepared quick template. The method is explained in this message by David Kirk: https://www.ritlabs.com/en/auth-forums/forum4/topic13528/message46382/#message46382

I hope this helps, even if I may have misunderstood your question :)
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
Hi Daniel,

thank you for your quick reply.
Regarding the Download manager I'm not totally sure it only works for the incoming messages. In version 8.7 the links included in the signature were automatically white listed (You could check them through the Configure button. HTML Viewer --> Download embedded images from external sites). In fact all the signature downloadable images were correctly shown. Now, in version 9.3, the same images are "black listed" and I cannot find a way to make the visible.This is the problem.  
 
Yes, I assume that when you view your own sent HTML messages, they will get the same treatment that incoming messages get. But what I meant is that the download manager should not hinder your linking to external images, and that it won't affect the display of the images on the recipients' system.

Having said that, it is definitely weird that apparently some URLs are still being blocked if you are allowing the download of all external images. Are you positive that the URLs are correct and that you don't have a firewall or equivalent software that's blocking them? If so, I think it would be good if you report this to the developers using the Support menu above.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
A suggestion: since you are concerned on how TB! shows your signature in an email, I suggest sending a message to yourself and then viewing in a different email client, such as Thunderbird. That should confirm where your problem lies. If it is not showing correctly, then downloading is not the issue. Good luck.

david
 
Hi David and Daniel.

I tried to follow the procedure David provided a while ago (using quick templates) but the outcome is not good. Things are misplaced all around the mail body. I believe TB! uses its own hmtl interpreter which differs from the OS one (of course I might be wrong, I do not master html). The only way I found to display html the right way is through Macros --> Include a templete Files and sel ect locally on disk the html signature. In this case, I assume, the TB! "html engine" is bypassed and things are shown correctly (except the images). I've checked an email sent fr om my TB! account with another email client and I see the same exact signature outcome.
An alternative could be to take a snapshot of the signature as it should be and paste it in place of the current hmtl signature.
Daniel, you talked about attaching the signature to the email. How does it work?

Thank you!  
 
Quote
Daniel, you talked about attaching the signature to the email. How does it work?

When you edit a message or a template in HTML format, you can use Utilities | Insert | Insert an Image (or the 'image' button in the toolbar) to insert a local image file, which will then be included with the message as an attachment.

It's best to use a small JPG or GIF file for this purpose, otherwise your message (and your archive of sent messages) will become very big.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
Pages: 1