The Bat! Help

Folders (6)
Macros (12)
Backup (4)

The Bat! Tools

  • Search
  • SmartBat
  • Scheduler
  • RSS
  • Inbox Analyzer
  • Image Download Manager
  • QR Code Generator
  • Export and Import Messages
  • Synchronization

  • Search

    The Bat! offers a handy tool to search messages. Using the Tools -> Search menu or pressing the F7 key you will open the "Message Finder" window.



    First define the search criteria in the Options section. To add a condition, click the "New condition" button. Note that if the “ALL strings should match (AND)” option is selected, the program finds messages that match all the conditions. In case “ANY string should match (OR)” is checked, The Bat! finds all the messages that match at least one of the conditions. In the lower part of the section select the folders which the program should search. To select all the accounts, click the "Select all" button. If you want to select all the folders in an account at once, use the "Select all in account" button. To quickly select folders, right-click a folder and choose one of the options from the context menu:



    Additional search criteria is available in the Advanced section. You can, for example, search messages with flags (not replied, unread, parked), attachments or messages received within a specified period of time. You can also perform "case sensitive search" or "search for whole words only".



    Messages that match the defined search criteria are displayed in the Results section. You can assign a view mode for the message list in this section: right-click a column title and select a view mode from the context menu. Use the View menu to configure your message list display (threads, headers, message list columns, etc.)



    To start or stop the search process, use the respective buttons on the right-hand side of the window. To start search you can also use the Enter key. If you need to set more complex criteria, switch to Advanced search. Web-like search is also available.



    0  

    SmartBat

    SmartBat is a small editor that allows making notes in a smart way. SmartBat maintains multiple pads, which are simple text files. Each pad is displayed on a separate tab.



    To open SmartBat, use the Tools -> SmartBat menu or press the F6 key. You can access SmartBat from the Scheduler switching to the Notepad tab.

    You can search (Ctrl+F) words or search and replace (Ctrl+F7) in SmartBat. Spell checker helps to avoid typos in SmartBat just as it does in the Editor.

    Context Menu

    In addition to standard commands (Copy, Cut, Paste, Delete), the context menu offers the following options:

    • Generate QR Code
      Use this option to generate QR-Code containing phone number, text, URL or email.
    • Format Block
      Choose text alignment: left (Alt+L), center (Alt+C), right (Alt+R) or justify (Alt+J).
      • Auto-Wrap
        When you type the text, it will automatically wrap to a new line if this option is enabled.
      • Auto-Format
        If this option is enabled, any change you make to the already entered text will reformat the paragraph.
      • Justify on autowrap
        If you enable this option, the paragraph will be block-aligned after wrapping.
    • Utilities
      • Insert Time Tag Line
        Insertion of a line with the current date and time to separate notes (Shift+Ctrl+T).
        ›======‹ 15.04.2015 19:27:56 ›====================(20150415)========
      • Insert current date
        Insertion of the current date at the cursor position.
      • Insert current time
        Insertion of the current time at the cursor position.
      • Evaluate
        Calculation of an arithmetic expression; the entire expression is replaced with the result.

        Note: The cursor must be in the line containing the first number/symbol of the expression. No spaces between signs and numbers are allowed. You can use brackets to separate operations. Example: (31+30+5+25)*17 will be replaced with 1547.
      • Copy to ...
        The selected text is copied to a new or existing text file.
      • Paste from ...
        A text file contents are pasted into the current pad.
      • Paste formatted
        The text from the clipboard is pasted formatted.
    • Save As ...
      This option allows to save your notes in a text file.
    • Next/ Previous Pad
      Use these options to switch between the pads.
    • Close Pad
      Closes your current pad (Ctrl+F4). Note that changes are automatically saved when you close your pad.
    • Always on top
      Enable this option to see the SmartBat window when working in other programs.
    • Show in Taskbar
      SmartBat is displayed on the Taskbar if this option is enabled.
    • Exit
      Exits SmartBat (Esc).


    0  

    Scheduler

    The Bat! offers a simple and handy scheduler to automatically create and send emails, perform actions (like running programs or opening files), re-filter folders and much more. To access it either use the Tools -> Scheduler menu (Alt+F11) or switch to the Scheduler tab from SmartBat.



    The main window of the Scheduler is divided into four sections:
    • The upper left field displays the groups of scheduled tasks. This grouping can be useful if you have many tasks and need to find the needed one quicker.
    • The lower left field is a calendar that you can use to find dates.
    • The upper right field shows the list of scheduled tasks.
    • The lower right fields contain four tabs that show information on the selected task.

    Creating a Task

    To create a new task in the Scheduler, choose the New option from the context menu of the task list or press the Insert key. The new window will appear where you should configure the new task.

    Changing a Task

    To change the settings of a task, right-click it and select Properties (Enter).

    Task Properties



    Input the task name in the Description field. This name will appear in the task list.

    Specify the date and time of the task start. You can also define the duration of the task if needed.

    If you want to automatically execute this task, check the "Enabled" box.

    You can set the priority for any task. The high and highest priority affects the sorting in the "Today", "Tomorrow" and "This Week" groups.

    To get a notification before an event starts, enable the "Notify me about this event" option. Specify the time when the notification will appear.

    If The Bat! is not running at the time the event should start, the task will not be executed. If the "Notify about up to … missed events on startup" option is enabled, you will get a notification about missed tasks on program startup. If the "Execute actions for missed events" checkbox is selected, The Bat! will execute missed tasks.

    Click the "Notification parameters" button to configure the notification.



    Choose a sound by clicking the Browse button. You can also enable the "signal using system speaker" option if needed. The notification sound can be played several times until you confirm it.

    If you check the "Activate the notification window" box, a notification window will open before your event starts:



    These notification settings can be "used as default" for all the new tasks.

    Actions

    In the Actions section you should specify the tasks this event will execute. You can add actions that should be performed when the event starts and finishes.



    Click "Add" and choose the actions:
    • Start a program
    • Send/Check mail
    • Create/Send message
    • Automatic reply
    • Open linked documents
    • Watch and Send files
    • Perform Folder Maintenance
    • Refilter messages
    • Backup
    • Send messages
    • Analyze messages
    To edit or delete an action use the respective buttons.

    Some of the frequently used actions are described below.

    • Send/Check mail



    Choose one of the available actions to perform:
    • Check for new mail only – This event invokes the “Receive new mail” command (F2)
    • Send Queued messages only – Messages in the Outbox folder will be sent at the specified time; this event invokes the “Send queued mail” command (Shift+F2)
    • Check and send simultaneously – If you select this action, the program will send the queued mail and check the mailbox for new mail at the same time
    Besides the action you should also specify the accounts to process.

    If you disconnect from the Internet, you may enable the "Connect to the Internet if needed" option. The "Disconnect when all sessions finished" option allows disabling the dial-up networking connection.

    • Create/Send message



    First of all you should specify the account that will be used to send messages. Select an account from the dropdown menu of the Use account section.

    Specify the recipients in the "Create message for" section. If the "Linked persons/addresses" option is selected, you should add the recipients in the Links section of the event. If you check "Specific addresses" you can input the addresses in the field below or click "Browse" and choose them from your Address Book.

    Besides this you should specify the template that will be used for the new message. Select "Specific template" and click "Edit" to create it. You can use one of your Quick Templates: select "Use Quick Template" and choose it from the dropdown menu. If you want to attach files to the message, check the "Attach linked documents" box and add them in the Links section of the Edit Event window.

    Specify what action to take:
    • Send immediately – The message will be sent at the time the event starts
    • Queue in the Outbox – The message will be created, but not sent automatically – it will be put in the Outbox folder
    • Open in the Message Editor – At the time the event starts The Bat! will open the message in the Editor and you will be able to edit it
    • Save as draft in the Outbox – The message will be saved as draft in the Outbox folder
    To create a personal message to each recipient, enable the "Create separate message for each addressee" option. If you do not activate this option, the program will create one message and add all recipients into the To field.

    • Perform Folder Maintenance


    Scheduler can perform folder maintenance as well.

    First of all, you should select the folders to process: use the Select All/Deselect All buttons to quickly select/deselect all folders.

    The following actions can be performed:
    • Check Integrity/Repair
    • Remove Duplicates
    • Purge old/exceeding messages
    • Compact (remove deleted messages)
    Check the "Run in background" box if you do not want the folder maintenance window to pop up when the event is executed. You can stop the folder maintenance process by clicking the respective button.



    • Refilter messages


    Scheduler can automatically re-filter messages. Select an account and its folders whose messages should be re-filtered.

    Select a filter set from the dropdown menu and mark filters to be used. Use the Account -> Sorting Office/Filters menu if you need to create new filters.

    You can choose between two process log types – "progress bar" or "extended details". The log can be hidden if you do not need to check the results.



    • Backup
    For more information about the Backup task, see the article Configuring automatic backup.

    Recurrence

    Switch to the Recurrence tab to define when the task should be repeated. If you set recurrence you can define when the repeating will be stopped (occurrences or date).

     

    Once you check the "Repeat this event every" box, the Advanced tab appears. Switch to it to set a more exact repeating frequency (time, days, weeks, months). For example, the program can execute the tasks on certain days of weeks or months.



    Links

    In the Links section you can add contacts and files that will be attached to messages. This section contains all URLs, files and address book entries associated with the task.

    If you use the "Remind later" command, the link to the message will be displayed in this section.

    You can add persons from your address book. To access a contact’s information for editing purposes click the "Edit" button.



    Categories

    You can add your own task categories (e.g. Personal, Work, Internet, etc.). To add a category, specify its name and handle. On the memo tab, you can add a descriptive text.



    0  

    RSS

    RSS is a technology that allows fetching news published on web-sites, blogs or forums. If you subscribe to RSS feeds in The Bat!, all the news and forum posts will be automatically fetched, combined and displayed in one list just like the ordinary emails are. This significantly increases the efficiency of your work, as you no longer need to visit web-sites or forums for updates.

    To subscribe to an RSS feed, you should copy its URL and add it to The Bat!

    Let’s take a look at subscribing to RSS feed available on our website:

    • Go to the main page of our website and copy RSS feed URL from the news section

    • In The Bat! go to the Tools -> RSS menu and choose "Subscribe"

    • Insert the link into the Feed URL field and press "Test"

    • If the URL was successfully tested, press OK – The Bat! will create a new account RSS subscriptions with the respective RSS feed folder.
    The message list of the RSS folder is presented in the summary view, which you can also apply to other accounts under the Options -> Preferences > Message List menu. The news can be displayed in two modes: a short news summary is shown on the Summary tab and the entire text of the news is displayed on the Entire text tab. You can mark news as read/unread, flagged, parked as well as delete them.


    RSS Feed Subscriptions are updated at program startup and periodically every 10 minutes, which allows following news in all your RSS subscriptions. News is marked as read when it is being read for 2 seconds. You can change these account settings under the Account -> Properties menu or on the Information message list tab.





    You can also enable the "Empty Trash folder" and "Compact all folders on exit" options. If needed you can disable updating a feed by deactivating the "Enable feed" option under the Folder -> Properties menu.

    It is possible to import and export subscriptions into the *.opml format using the Tools -> RSS menu.

    You can create an RSS Aggregate folder using the Folder -> New -> RSS Aggregate Folder menu. It displays all the news from its subfolders.



    To move an RSS folder into an RSS Aggregate Folder select it and move it beneath the Aggregate Folder. Then invoke the context menu and choose "Move In" (Shift+Ctrl+Right).

    You can subscribe to an unlimited number of RSS feeds and follow the news directly in The Bat!


    0  

    Inbox Analyzer
    Inbox Analyzer is a handy tool that helps you handle emails efficiently. It analyzes emails stored in the Inbox folder, divides them into groups depending on their senders and date and suggests actions. Inbox Analyzer allows for creating an efficient set of filters that automatically sort messages to folders.

    To access the Inbox Analyzer use the Tools -> Inbox Analyzer menu.



    First select the accounts to process. Once you click OK, the Inbox Analyzer will start the process.



    The Inbox Analyzer will display the list of correspondents and suggest an action for each of them. In the Tag column you will see the category of the message group (for example, newsletter, old newsletter, mailing list, old correspondent and so on).

    To change the suggested action, select a correspondent in the list and choose an action from the dropdown menu:



    • Skip – Select this option if you do not want to perform any action for this correspondent
    • Delete messages – The Bat! deletes all messages from this sender
    • Move to folder – The Bat! creates a new filter in the Sorting Office that will move all the messages from this sender to a specified folder
    • Mark as Spam – Messages are moved into the Spam folder and The Bat! creates a new filter in the Sorting Office that will automatically mark messages from this sender as read and move them to the Spam folder in future
    • Move to Archive folder once – The Bat! moves messages to the Archive folder, however, no filter is created in the Sorting Office
    • Move to Ignore List – Messages from this sender will not be analyzed in future
    • Recommended – Select this option to perform the suggested action
    To perform the actions click the "Execute action" button. If you do not want to process messages from a certain correspondent, select it and click "Delete selected". "Ignore list" contains those correspondents whose messages are not analyzed. If you want to configure the Inbox Analyzer, click the "Edit settings" button.

    Using the Options -> Preferences -> Other options -> Inbox Analyzer menu you can access its settings as well.



    The Group new folders in the root folder field displays the name of the folder where the subfolders for spam and archive messages are created. It is the Analyze folder by default.

    The default folder for old messages is the Archive folder. Messages marked by the Inbox Analyzer as spam are moved to the Spam folder. You can rename these folders if needed.

    Click the "Accounts" button to select the account(s) for analysis.

    If the "Re-filter mail" option is enabled, messages will be re-filtered after you close the Inbox Analyzer. If the "Focus Inbox" option is active, the cursor will move to the Inbox folder when processing messages.

    You can specify the minimal number of messages to form a group. The default number is 20.

    If you want the Inbox Analyzer to process messages automatically, define the conditions to get it started: "Every…days" or "Number of new messages is more than…". By default, the Inbox Analyzer processes messages every 10 days. To disable the Inbox Analyzer, uncheck this box.

    You can define the "start-up time" for the Inbox Analyzer. If the program is not running at this time but the "Run later if that time is missed" option is active, the Inbox Analyzer will start once you launch the program next time.

    "Ignore list" contains correspondents whose messages are not analyzed. You can edit, delete or paste addresses from the clipboard.

    0  

    Image Download Manager

    Image Download Manager is a tool for background image retrieval which prevents malware from reaching your computer through graphic elements of HTML messages. It blocks the suspicious images and lets the safe ones through.



    To access it use the Tools -> Image Download Manager menu. You can add your own filters to allow or deny image retrieval by URL, folder or sender’s email address. To create a new filter use the "Create Rule" or "New" buttons. You can delete or edit rules at any time.



    For example, you can block banners by URL or image retrieval in the newsletter folder.

    If you are sure the images are safe you can download them all clicking the "Download All" button.
    To allow image retrieval for messages from a certain sender or website, click the icon on the right-hand side of the headers pane.

    0  

    QR Code Generator

    QR Code Generator allows creating QR codes which represent black modules arranged in a square pattern on a white background. QR Codes contain encoded information. Using mobile device camera and QR Code scanner you can quickly decode such information.

    QR Code Generator allows transferring text information from The Bat! into your mobile device or tablet directly from the screen of your monitor. You can encode any text – Email addresses, phone numbers, quotations from messages, address book contacts and so on.

    Here are some of the tasks you can do while using the QR Code Generator:
    1. Transfer your contact from The Bat! address book to your mobile phone address book
    2. Select message text in The Bat!, transfer it to your mobile phone and send as an SMS
    3. Transfer and save a hyperlink from a message to your mobile phone
    4. Encode a phone number from a message to add it to your mobile phone contacts
    There are several ways to access the QR Code Generator. While reading or composing messages you can just select text, email address, URL, phone number etc., right-click it and select "Generate QR Code".

    QR Code Generator can be accessed when the selected text is in the following program areas:
    1. Main Window:



    2. Message Editor Window:



    3. SmartBat Window (Use the Utilities menu or right-click the text):



    4. Address Book Window:



    The Bat! recognizes email addresses, URLs, phone numbers and simple text, inserting this information in the corresponding fields of the generator.

    For example, if you received an email with a request to call the given phone number, you can right-click the number and choose Generate QR Code -> Phone Number. The program will generate a code containing this phone number. Once you scan it using the mobile phone camera, you can quickly dial it or add to contacts.



    QR Code Generator form contains the following tabs:
    1. QR Code – Contains the generated image
    2. QR Source – Shows the fragment used for generating the current QR code
    3. URL – Allows entering a URL to generate a QR code
    4. Text – Allows entering text to generate a QR code
    5. Phone – Allows entering a phone number to generate a QR code
    6. SMS – Allows entering information consisting of phone number and message text to generate a QR code with SMS attribute
    7. Bookmark – Allows entering information consisting of a URL and bookmark name text to generate a QR code with bookmark attribute
    8. Email – Allows entering an email address to generate a QR code
    9. Send Email – Allows entering information consisting of an email address, message subject and text to generate a QR code with send email attribute
    10. vCard – Allows entering information consisting of the first name, last name, email address, organization and website address to generate a QR code with vCard attribute
    11. meCard – Allows entering information to generate a QR code with meCard attribute
    12. Geolocation – Allows entering information consisting of location, latitude and longitude to generate a QR code with geolocation attribute
    13. Wi-Fi Access – Allows entering information consisting of SSID, password and network type to generate a QR code with information for Wi-Fi access
    In the lower part of each tab you can see a QR code size indicator that prevents you from exceeding the size limit. There are also buttons for various actions: Copy (copies the current QR code into clipboard), Save as (saves the current QR code as a graphic file), Apply (generates QR code from the entered information) and Close (Closes the Generator window).

    For more information, see the article in the Tips and Tricks section.

    0  

    Export and Import Messages

    The Bat! can import and export messages.

    To export messages use the Tools -> Export messages to menu and select one of the formats: Message files (.MSG), Message files (.EML), UNIX Mailbox.

    To import messages, use the Tools -> Import messages menu and select one of the options: from .MSG/.EML-files, from UNIX-mailboxes, from The Bat! message base v2 (.TBB) or from The Bat! message base v1 (.MSB). If you want to import messages from another mail client, select the "Mailbox Import Wizard" option.

    For more information about message import check out the article.

    0  

    Synchronization

    Some of us use two or more computers every day, which makes it necessary to synchronize data stored in The Bat! The program offers a tool that allows synchronizing data on two computers that have full access to a shared folder.

    Start The Bat! and access the Tools -> Synchronize menu on both computers.



    Select those elements that should be synchronized. If you want to synchronize certain folders only, check the "Let me specify the folder list" box.

    Click the "Browse" button and point to the shared folder on both computers. Click OK to start the synchronization process.

    Accounts, folders and messages will not be duplicated when synchronized – Only the missing information will be added in both copies of the program.


    0