The Bat! Help

Folders (6)
Macros (12)
Backup (4)

Folders

  • Virtual Folders
  • View Modes
  • Maintenance Center
  • Folder Properties
  • Sorting Filters
  • Account Tree

  • Virtual Folders

    Virtual folders help you simplify your workflow, especially when you use several accounts. Virtual folders display only those messages that satisfy the conditions you set. A virtual folder can be displayed as an account folder/sub-folder or as a common folder.

    Virtual folders do not contain messages, but only references to them. Messages are stored in their source folders and are watched by the virtual folders. Do not forget that any changes you make in virtual folders will affect the original messages.

    You can use virtual folders to display unread or flagged messages, messages that you received this week, etc. You can also define many other conditions.

    To create a virtual folder, use the Folder -> New -> New (Common) Virtual Folder menu. You can access this menu from the context menu of the account tree as well.

    The settings in the General section of the "Create a New Virtual Folder" window are identical to the settings in the same section of the "Create a New Folder" window. Go to the Filter section to configure filter settings.

    If you check the "Auto refresh" box, the virtual folder will show the current state of the messages. Mark the "Store state between sessions" check box to make The Bat! remember the messages displayed before exiting.

    The Bat! counts the number of messages and displays it in the account tree. Parent folders include the number of messages of their sub-folders. As virtual folders do not contain messages but only references to them, the number of messages in the virtual folders is not taken into account. You can change this setting by selecting the "Count in upper level" option.

    Enable the "Use fast search" option to set your search criteria. You can watch unread, parked, flagged not replied messages or messages that contain attached files. If you need to add other criteria, enable "Advanced filter settings" and configure the filter just as you do it in the Sorting Office.

    Click ОК to start choosing the folder your new virtual folder will show messages from. After you choose them, click OK to finish creating the new virtual folder.

    You can create virtual folders from the "Message Finder" window as well. Open it using the icon and enter the search criteria. You can directly create a virtual folder from the results by clicking the "Virtual Folder" button. Search conditions will turn into a filter of the virtual folder. You can change them, if needed.


    0  

    View Modes

    View modes allow you to change the message list display in different folders.

    The program has five default view modes:

    • Generic View Mode – All the messages are shown in one list with the standard column set
    • This week – The folder displays only this week’s messages
    • Threaded view – Messages are grouped into threads based on the selected criterion
    • Today – The folder displays only today’s messages
    • Yesterday – The folder displays only yesterday’s messages

    You can edit the existing view modes or create new ones. To configure view modes, use the Options -> Preferences -> Message List -> View Modes menu. You can open this dialog when right-clicking a folder and choosing the Folder View Mode -> Manage View Modes menu.

    Choose the action that will be performed upon changing the view mode in the message list: "Ask confirmation for save","ignore changes" or "save". So if you manually change the column width, you will get a confirmation dialog box if the first option is selected. If you choose the second option, the changes will not be saved. In the third case, the program will save changes without confirmation.

    Click "Use by…" to choose folders in which the selected view mode will be used. You can assign different view modes to different folders. You can create a new folder that will display only today’s or this week’s messages.

    To add a new view mode click the "New" or "New from" button. In the first case you will create a brand new view mode (based on the generic view mode), in the second case – a view mode based on the settings of the selected view mode. To alter the settings, select the view and click "Edit".

    To remove a view mode, use the "Delete" button. It is not possible to delete the generic view mode.

    When you create or edit a view mode, you will get the "View Mode Setup" window. Give the view mode a name; if you edit a view mode, you can change its name. If you select the "Group by date" check box, messages will be grouped into the following threads: today, yesterday, this week, last week, etc. You can define by which message headers your messages should be threaded:

    • References – Replies to messages can be identified by their headers (technical information that is not seen when reading message, but used by email clients). This threading uses the headers In-Reply-To and References to group messages
    • Subject – Such thread includes messages with identical subject lines. The prefixes that are added to the subject when replying/forwarding messages, are not taken into consideration
    • Sender – Threads include messages with the same sender’s name and address
    • Recipient – Threads include messages with the same recipient’s name and address
    • References and subject – The program uses both references and subject criteria to form a thread

    Threads by references are considered to be the most reliable and handy, though the other ones will also be useful for certain goals.

    Any thread is collapsed by default and to view it, you should expand it first. You can change this setting by selecting the "Expand all threads" check box.

    You can define which columns you would like to see in the message list. For example, there is no need for the To column in the Inbox folder. A standard view mode has the following default columns: Message flags (read/unread, replied, forwarded flags and priority), Parking, Attachments, Flagging (your own marking), From (sender’s name), To (recipient’s name), Subject, Received (date and time when you received the message), Created (date and time of message creation), Size (size in bytes). Messages are sorted by the Received column by default – they are displayed according to the time you received them, starting from the new down to the older ones. You can change both sorting criteria and sorting order (descending or ascending order).



    Columns and their order are different in the Threaded view: Subject, Message Flags, Parking, Attachments, Flagging, From, Received, Total messages (number of messages in this thread), Unread messages (number of unread messages in this thread), Created and Size. If a thread is collapsed, the program displays the information on the newest message.



    While configuring a view mode you can add the following columns: Priority (message importance), Folder (source folder of this message), Color group, Memo, Message ID (a unique ID that is automatically assigned to a message), From (email) (sender’s email address), To (email) (recipient’s email address), Modified (date and time of the last message modification), Tags.

    Each column has its width. Choose a column and set its width in pixels. You can also change it in the message list using the mouse (press and hold the left mouse button and drag column borders). Use the "Move up" and "Move down" buttons to change the column order.

    Sometimes a new message appears in an old thread. In this case the thread will not be moved to the top of the message list, as the program sorts threads according to the date of their first message by default. You can change this setting and display threads with new messages at the top of the list – just tick the "Thread dates according to new messages" box.

    To add more complex conditions go to the Filter tab. The program will display only those messages that satisfy the conditions of the view mode. Here are the filter conditions of the view mode Yesterday:



    You can add several conditions and combine them according to your sorting needs.


    0  

    Maintenance Center

    It will take you much time to compact each folder manually. The Maintenance Center will help you compact all the folders of your accounts at once. To open it, access the Folder -> Maintenance Center menu.

    A new window will appear where you can see the information on each folder, such as folder size and total number of deleted messages. You can select all the folders or only certain ones.

    You can perform the following actions:

    1. Check Integrity/Repair: If you select this box, The Bat! will check your message base. If the message base is damaged, the program will try to repair it. Damaged parts are saved into the files with a .BIN extension, so you can view them using a text editor and save any relevant information.
    2. Remove Duplicates: The Bat! will find and delete duplicates in each folder. Messages are considered duplicates if their "From", "To", "Message-ID" and "Date" attributes are equal, even if other parts are different. If a message has no "Message-ID", then the "Subject" is used instead. You can exclude one or more parameters from the comparison by using the command line parameters.
    3. Purge old/exceeding messages: If you set the maximum age and number of messages in the folder properties , then you can execute the deletion of the old and exceeding messages here. Such messages can also be automatically removed on exit if you enable this option.
    4. Compact (remove deleted messages). Whenever you delete a message from a folder, it gets marked as deleted and is not displayed in the folder, but is still physically stored in the message base. This allows you to view and restore messages you have deleted accidentally. After you purge a folder, messages disappear from the message list but the space they occupied on the drive is still in use. When you compress a folder, the program rewrites your message base without the deleted messages to save disk space and enhance overall performance.

    Select the actions you would like to have performed and click the "Start" button. To stop the process, use the "Stop" button. The speed of the process depends on the message base size. Finally, you will see a dialog box with the results.


    0  

    Folder Properties

    To access folder settings, right-click the folder and use the Folder -> Properties menu (Alt+Enter) or choose "Properties" in the Folder menu.

    Folder settings are divided into the following sections: General, Additional, Templates, Sound, Identity, Deletion and Memo.

    In the lower part of this window you can see the "Watched by" button. If you click it, you will be able to define virtual folders that will watch this folder.

    In the General section you can:

    • Change Folder Name
    • Change Parent Folder
    • Define, if the messages from this folder will be shown on the Mail Ticker
    • Configure folder-specific Print Settings
    • Set the default Character Set for messages in this folder

    In the Additional section you can:

    • Define the directory where the folder’s message base files (MESSAGES.TBB and MESSAGES.TBN or MESSAGES.EBB and MESSAGES.EBN if you use mail base encryption) will be stored
    • Set the "maximum number of messages" stored in the message base
    • Set the maximum age of messages stored in the message base
    • Choose actions that the program performs on exit – "remove old messages" and/or compact folder

    You can change the following folder Templates:

    • New message
    • Reply
    • Forward
    • Confirmation

    To set the melody that will be played when a new mail arrives in this folder, access the Sound section. The program uses the same sound as you set in the account settings, however you can change it and use own sound settings or disable sound for this folder. If you choose your own sound settings, then you can define the time interval during which it will be played.

    Set the name and the email address that your recipients will see in the "From" and "Reply-To" fields in the Identity section. For example, if you use the folder for personal correspondence, you can remove the organization you work for.

    To set folder-specific deletion settings, open the Deletion section. By default, if you press the Delete key, messages are moved to Trash, and when you press the Shift+Delete key combination the program deletes messages immediately, without placing them to Trash. Such alternative deletion is applied to old messages that are stored longer than the period you set in the Additional section.


    0  

    Sorting Filters

    The Bat! offers a filtering system that will help you automatically sort out and otherwise organize your daily correspondence. This filtering system is called Sorting Office. The Sorting Office is a tool that you can use for performing some other tasks as well.

    To access the Sorting Office, use the Account -> Sorting Office/ Filters menu (Shift+Ctrl+S).

    First select a category - incoming mail, outgoing mail, read messages, replied messages or selective download. The first four categories are meant for sorting tasks, the last one – for combating spam. To create a new filter, select the needed category on the left-hand pane and use the File -> New Filter menu or click the icon

    If you have several accounts, you should choose the account in which your filter will be active or define it as a common filter. Specify the filter name, add a condition by clicking the "Add condition" button and an action by clicking the "Add" button in the Actions pane. 

    The "Move to a folder" filter which you see on the screenshot moves all incoming messages to the Support sub-folder if the sender is in the address book. To move messages to a folder that does not exist, remember to check the "Automatically create if necessary" box.

     

    The filter performs actions only when it is active. New filters are active by default.

    To check whether a filter performs actions correctly you can test it. Right-click an email and select the "Test Filters" option under Message.



    Select the category of filters that you will test. Click OK to start filtering. Check the results: if the number of processed messages coincides with the number of filtered messages, the filter works correctly.



    You can use filters for re-filtering of the already downloaded messages. Right-click a folder in the account tree and select the "Re-filter" option (Ctrl+F).

     

    Choose filter category and click OK. Your filters will trigger and you will see results in a new dialog box.


    0  

    Account Tree

    The Bat! stores messages in folders that are displayed in the account tree.

    Once you add an account, The Bat! creates four default folders: Inbox, Outbox, Sent Mail and Trash. You will not be able to delete them.

    When you delete an email using the "Delete" key, the program moves it to the "Trash" folder. While this message is there, you can restore it. If you delete a message from Trash, you will not be able to restore it, though there is one exception: if you have not yet compacted the folder, you can view it using the Folder -> Browse deleted messages menu. The program will display the deleted message strikethrough both in the Trash and in its source folder. To restore it, select it and press the "Delete" key.



    You can create sub-folders with their own structure within the default folders. Filters will help you automatically move them into different folders and organize incoming or outgoing emails.

    To create a folder, access the Folder -> New -> Folder menu. The new folder will be created as a subfolder of the currently selected folder. The other way to create a folder is to right-click the folder and select the New -> Folder option (Insert).



    The "Create a New Folder" window will appear. Here you can set the name of your new folder, configure print and column settings and define the default character set. Select the "Show unread messages on MailTicker" check box if you want to get notifications of new messages on the MailTicker.



    In the Additional section you can set the "maximum number of stored messages" and define how long they should be stored in the folder. The Bat! can then automatically "remove old messages on exit" if you enable the respective option. You can as well set the program to compact folders on exit. When you compact a folder, the program removes deleted messages from the message base file of this folder.



    The settings in the Templates and Sound sections are the same as the respective settings in the Account properties, however they are applied only to this folder.

    The outgoing emails contain the information on the sender (email address, name, etc.) defined in the account properties. You can define an email identity for any folder you create in the Identity section. Set the name and the email address that your recipients will see in the "From" and "Reply-To" fields. For example, if you use the folder for personal correspondence, you can remove the organization you work for from the "From" field.



    To set folder-specific deletion settings, open the Deletion section. By default, if you press the Delete key, messages are moved to Trash, and when you press the Shift+Delete key combination the program deletes messages immediately, without placing them in the Trash folder. Such alternative deletion is also applied to old messages that are stored longer than the time range you set in the Additional section.



    Once you create a folder, the program displays it in the account tree. If it is created in a default folder, you will see the number of messages stored in this sub-folder in brackets to the right of the default folder name.



    To delete a folder, select it and press "Delete". Alternatively, you can right-click the folder and choose the "Delete" option. You will see a confirmation dialog box. You can move the messages from this folder to Trash, wipe them or leave them in the message base. If you choose the last option, the folder will disappear from the program’s interface, but you will be able to restore messages using the Tools -> Import messages menu. To restore the folders that are still kept in the mail directory, use the key combination Ctrl+Alt+Shift+L.



    You can sort out messages to folders manually. To move a message, select it and simply drag and drop it into the folder in the account tree. The message will disappear in the source folder and appear in the folder you moved it into. To copy a message press and hold down the Ctrl key while you drag the message.

    To move folders in the account tree use these key combinations:



    Select a folder, press and hold down the Alt key to move it manually. Press and hold down the Ctrl+Alt key combination while you drag a folder to move it into another folder.


    0