Pages: 1
RSS
Google security alerts
 
Hello,

I am running TheBat v7.4.16. I keep getting Google security alerts when I am connecting with my IMAP email accounts, so I have to configure them as "less secure". Has this been fixed in version 9 ?

Thanks.
 
Maybe you can search the forum for your specific error messages, or for the many Google-related discussions that we've had in recent years. Many things have been fixed (in some cases only to have Google change them again and creating new problems).
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
Searching the forums for: invalid credentials (failure)

"Your search did not match any documents. Try different keywords."

After the "invalid credentials" message in TheBat I get a warning from Google :

"Less secure app blocked
Google blocked the app you were trying to use because it doesn't meet our security standards."

Searching the forums for: less secure app blocked
Got 1 post from 2019, not answered as of now.

So is v9 properly secure for google?
 
Quote
Neofit26 wrote:
So is v9 properly secure for google?

Of course it is. It's the current version of TheBat and countless users have gmail accounts. Personally I use v8.8.2 with Gmail. I don't know if your v7 can also be made to work with Gmail, but again, there have been many discussions here about options and settings that can be used to make older versions work.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
One can make v7 work with gmail IMAP accounts, if one allows "less secure apps" to connect in their google account settings. Fr om what I've read google likes to change their "secure account" specifications, and then developers often have to catch up with them. So the current v9 is compatible with today's google secure account specifications? We're not on Amazon where we have 30 days to request a refund and I don't want to pay 36€ for an upgrade for nothing. Other than this issue and TB not remembering what branches of the accounts/folders treeview were open last time it was closed, I am quite happy with v7.

Thanks for the patience.
Edited: Neofit26 - 17 January 2022 11:13:12
 
You can always try trial without any money payment.
Модератор. Не являюсь сотрудником RitLabs (I'm not an employee of Ritlabs). https://belrus.biz/vendors/ritlabs.html
 
Quote
Neofit26 wrote:
We're not on Amazon where we have 30 days to request a refund

No, we're on Ritlabs.com, where we can download and evaluate a program for free even before spending any money on it!  :-D

But yes, to my knowledge, versions 9.0.14 and up work fine with Gmail's current OAuth 2.0 standards.
I volunteer as a moderator to help keep the forum tidy. I do not work for Ritlabs SRL.
 
Can this be a case of Google wanting you to use a special password? That's what I had to do. Go to your Google accounts page, then Security->Third-party apps with account access, then choose "Manage third-party access". I don't remember the exact steps after that, but you should be able to search for it. What you end up with is a special password that Google creates for you. You would put this in The Bat as your IMAP password. That worked for me a while back when Google blocked The Bat from getting email.
 
Sad but true - TheBat 7 and 8 isn't fully compatible with Gmail. You can find here on forum some workarounds, but there is no any chance that you will have ability to restore work with Gmail on "old" version.

Try the last version and do buy upgrade if you won't to waste a time.
Модератор. Не являюсь сотрудником RitLabs (I'm not an employee of Ritlabs). https://belrus.biz/vendors/ritlabs.html
Pages: 1