Справочник The Bat!

Написание писем

  • Прикреплённые файлы
  • Таблицы перекодировки
  • Проверка орфографии
  • Отложенная отправка
  • Отправка и сохранение письма
  • Адресация письма
  • Создание письма (HTML)
  • Создание письма (Простой текст)
  • Формат письма

  • Прикреплённые файлы
    В The Bat! существует четыре способа прикрепить файлы к письму:

    Способ 1
    В окне редактора писем воспользуйтесь кнопкой Прикрепить файл на панели инструментов и выберите необходимый файл или несколько файлов.

    Способ 2
    В окне редактора перейдите в меню Инструменты -> Прикрепить файл (комбинация клавиш Alt+PageUp) и далее укажите нужный файл.

    Способ 3
    Прикрепить файлы к письму можно, перетащив их мышкой в окно редактора.

    Примечание
    : чтобы вставить изображение в тело письма, установите HTML формат письма в меню Свойства -> Формат письма и перетащите изображение в окно редактора. Изображение можно добавить не только в тело письма, но и как вложение: для этого перетащите изображение в окно редактора и отпустите курсор над панелью заголовков – вложение будет отображено на панели прикреплённых файлов.

    Способ 4
    Если почтовый клиент The Bat! установлен в вашей системе как обработчик MAPI, то прикрепить файл можно следующим образом: выделите файл, нажмите правую кнопку мышки и в контекстном меню выберите Отправить по -> Электронной почте.

    0  

    Таблицы перекодировки
    Таблицы перекодировки определяют соответствие символов выбранного алфавита символам алфавита в национальной кодовой странице Windows.

    Так, например, для писем, составленных на русском языке, наиболее часто используются две таблицы: Cyrillic (Windows), известная как Windows-1251, а также Cyrillic KOI8-R.

    Если при просмотре письма указана неверная кодировка, то прочесть его будет невозможно. Если же вы напишете письмо, используя нестандартную кодировку, то скорее всего получатель также не сможет прочесть его.

    Если, например, ваше письмо составлено из кириллических и латинских символов, то стоит использовать кодировку Unicode (UTF-8) – в этом случае проблем при прочтении письма возникнуть не должно.
    Установить кодировку можно в редакторе в меню Свойства -> Перекодировка или на нижней панели:

    Добавить таблицы перекодировки в список, доступный в редакторе писем, можно в меню Свойства -> Настройка -> Другие опции -> Наборы символов.

    0  

    Проверка орфографии
    В The Bat! вы можете использовать проверку орфографии в редакторе писем. Для этого в редакторе перейдите в меню Орфография и выберите одно из действий:
    • Автоматическая проверка – проверка орфографии будет осуществляться непосредственно в момент написания «на лету» (комбинация клавиш Ctrl+F4). Вы можете включить автоматическую проверку орфографии, нажав на соответствующий значок на нижней панели;
    • Проверить весь текст – проверка орфографии всего набранного текста (горячая клавиша F4);
    • Проверить текст от курсора – проверка текста, расположенного после курсора (комбинация клавиш Shift+F4);
    • Проверить перед отправкой/записью – текст будет проверен на ошибки непосредственно перед отправкой письма, а не в момент его составления, как в случае автоматической проверки орфографии.
    Чтобы осуществить проверку текста на орфографические ошибки, необходимо, прежде всего, выбрать язык для проверки в меню Орфография -> Языки. Словари, которые входят в стандартный пакет установки, отображаются в данном списке. Вы можете выбрать языки проверки орфографии также в нижней панели окна редактора, нажав на соответствующую область:



    Вы можете выбрать несколько языков одновременно – в этом случае The Bat! будет осуществлять проверку орфографии в соответствии со словарями данных языков.

    В меню Орфография -> Параметры вы можете задать необходимые настройки проверки орфографии.

    В меню Орфография -> Словари можно отредактировать пользовательские словари. Текущий пользовательский словарь выберите из выпадающего меню поля Файл. Вы можете Добавить или Удалить слово из выбранного словаря, воспользовавшись соответствующими кнопками. Добавленные слова можно экспортировать в текстовый документ, нажав на кнопку Экспорт. Вы можете также импортировать слова из простого текстового документа. Для этого нажмите кнопку Импорт, выберите текстовый файл и далее определите, какие из слов стоит добавить в словарь.



    При автоматической проверке орфографии слова, содержащие орфографические ошибки, подчёркиваются красной линией. Наведите курсор на подчёркнутое слово, нажмите правую кнопку мышки и выберите один из предложенных вариантов написания из контекстного меню.

    Любое слово, определяемое программой как неправильное, может быть исправлено вами, пропущено или добавлено в словарь пользователя.

    Из контекстного меню вы можете выбрать опцию Другие варианты и в поле Изменить на ввести слово, которым будет заменено неверно написанное слово. Это слово можно также добавить в текущий пользовательский словарь, выделив его и нажав кнопку Добавить.

    Из контекстного меню вы можете также выбрать опцию Игнорировать, чтобы пропустить проверку слова. Выберите опцию Добавить в словарь, чтобы добавить слово в текущий пользовательский словарь – в будущем добавленное слово более не будет определяться как слово с ошибкой.

    Примечание: выбрать пользовательский словарь можно в меню Орфография -> Словари.

    При проверке орфографии всего текста или текста от курсора откроется диалоговое окно:



    Слова, которых нет в выбранных словарях, будет предложено заменить. Вы можете исправить слова или добавить новые слова в словарь.

    По завершении проверки появится окно с итогом – суммарным количеством проверенных и исправленных слов.

    0  

    Отложенная отправка

    При отправке почты могут возникнуть непредвиденные ситуации, например, отправка незавершенного письма, отправка письма не тем адресатам или без приложения необходимых файлов. Отменить отправку письма невозможно, приходится писать корректирующие письма, которые дополняют или исправляют предыдущие.

    Почтовая программа The Bat! позволяет избежать этих проблем, давая возможность пользователю указать задержку отправки писем. То есть пользователь может назначить относительное время отправки – задержку на определенное количество дней, часов или минут. К примеру, однажды указав в свойствах почтового ящика задержку на 15 минут для всех писем, пользователь потом нажимает привычную кнопку Отправить, и все письма уходят через 15 минут. В этот промежуток времени письма можно дополнить, изменить, удалить, отложить или задержать на более длительный срок.

    О том, как настроить отложенную отправку писем, рассказано в специальном руководстве.


    0  

    Отправка и сохранение письма

    По окончании написания письма можно выбрать, что с ним делать дальше – отправить сразу или отложить отправку. Если процесс написания письма нужно прервать, чтобы потом вернуться к нему, можно сохранить письмо как черновик. Кроме того, в целях предосторожности можно сохранить письмо в процессе создания, чтобы не потерять результат работы из-за системного сбоя или короткого замыкания. Все эти действия доступны в окне редактирования в разделе меню Письмо, а также на панели инструментов.



    Чтобы отправить письмо немедленно, нужно нажать первую из этих кнопок. Если нажать на стрелочку рядом с ней, можно воспользоваться опцией отложенной отправки и выбрать задержку либо назначить время отправки.

    Чтобы письмо было отправлено вместе с другой исходящей почтой, воспользуйтесь второй кнопкой. Письмо будет положено в Исходящие – чтобы отправить его (и другую почту), нужно перейти в главное окно программы и нажать кнопку  Отправить письма в очереди (комбинация клавиш Shift+F2) либо выбрать опцию Получить и отправить почту (все ящики) (горячая клавиша F11) в меню Инструменты.

    Для каждого почтового ящика в The Bat! можно настроить совмещенную доставку почты, при которой получение и отправка писем будут происходить одновременно. Также можно установить параметры автоматической проверки почтового ящика – через установленные интервалы времени программа будет сама проверять ящик на наличие новых писем, а при комбинации с совмещенной доставкой почты еще и отсылать исходящие письма. Все это можно сделать через меню Ящик -> Свойства почтового ящика, установив в разделе Транспорт галочку Совмещенная доставка (получение + отправка), а в разделе Параметры – галочку Проверять с интервалом в … минут/секунд. При желании можно также включить проверку почтового ящика при запуске The Bat!.



    Чтобы сохранить письмо как черновик, нажмите кнопку в окне редактирования. Письмо будет положено в Исходящие с использованием парковки – его невозможно будет удалить без подтверждения, а The Bat! не будет пытаться его отослать. Впоследствии можно будет продолжить работу с письмом.

    Если необходимо в целях предосторожности сохранить письмо в процессе создания, это можно сделать с помощью кнопки . Письмо будет припарковано в Исходящих, но процесс написания не будет прерван. В случае непредвиденного выключения компьютера сохраненная версия письма останется в Исходящих, и результат работы не будет потерян.


    0  

    Адресация письма

    При создании письма курсор автоматически помещается в поле Кому. Есть несколько способов указать получателя или получателей письма.

    1. Когда вы начинаете вводить адрес получателя, The Bat! проверит, не содержится ли в адресной книге запись с таким набором символов и предложит этот адрес. Может случиться, что введенные символы содержатся в нескольких адресах – тогда программа предложит все эти адреса. Можно либо продолжить набор адреса, чтобы уменьшить количество совпадений, либо выбрать из этого списка необходимый адрес.
    2. Если получатель письма есть в Адресной книге, можно начать вводить его имя или фамилию – и The Bat! предложит все совпадения. Нужное имя можно выбрать из списка точно так же, как в случае с адресом.
    3. Если при создании записи в Адресной книге был указан псевдоним получателя, можно ввести его. The Bat! автоматически подставит адрес, связанный с этим псевдонимом.
    4. Для выбора адресата можно воспользоваться Историей. В ней уже использовавшиеся адреса указаны в обратном хронологическом порядке – от недавних к более ранним. После нажатия на кнопку в правой части поля Кому появится выпадающий список, из которого можно выбрать необходимый адрес.
    5. Адрес можно выбрать из Адресной книги с помощью кнопки в правой части поля Кому. Откроется окно, состоящее из 2 панелей: слева – список адресов из Адресной книги, справа – список адресов, которые будут добавлены в соответствующие поля (Кому, Копия, Скрытая копия). Сверху слева есть поле, в котором можно выбрать любую из адресных книг и конкретную группу в ней. Есть также поле поиска адресов и поле для добавления к письму адреса, которого нет в Адресной книге.



      - добавить один адрес.

      - добавить все адреса из левой панели.

      - убрать адрес из поля справа.

      - убрать все адреса из текущей вкладки.

      - очистить все вкладки.

      - работа с фильтрами, поиском и буфером обмена.

      При работе с длинным списком контактов можно применить к нему фильтр. Для этого нужно ввести в поле поиска критерий фильтрации (например, первые буквы имени или фамилии) и нажать клавишу Enter. Отменить фильтр можно с помощью меню, которое появляется при нажатии кнопки со знаком вопроса. Бывают случаи, что в контакте указан не один электронный адрес, а несколько. Если установить галочку Добавить доп. адреса в поле "Скрытая копия", в поле Кому будет использован первый из этих адресов, а все остальные окажутся в поле Скрытая копия. Эта возможность полезна, если неизвестно, каким из адресов воспользуется адресат.

    Все эти способы можно применять ко всем полям, в которых указываются получатели: Кому, Копия, Скрытая копия.

    Поля Копия и Скрытая копия используются для адресации письма нескольким получателям. Особенность поля Скрытая копия заключается в том, что получатели, указанные в нем, не видят друг друга. Его можно использовать, чтобы не раскрывать адреса получателей. Однако некоторые почтовые серверы требуют, чтобы поле Кому было заполнено, поэтому укажите в нем хотя бы одного получателя.


    0  

    Создание письма (HTML)

    Формат HTML дает широкие возможности работы с текстом, графикой и таблицами. Чтобы создать письмо в формате HTML, выберите через меню Свойства -> Формат письма один из двух вариантов: Только HTML или HTML/Простой текст. При этом в окне редактирования письма появится новая панель – Форматирование.

    Через меню Стиль можно выбрать один из четырех предустановленных стилей написания текста.



    При выборе Обычного стиля будет установлен шрифт Courier New размера 9. Для стилей Заголовок используется шрифт Arial размеров 16, 14 и 13.

    В следующих меню можно выбрать шрифт и установить его размер. Письмо можно разделить на фрагменты и написать разными шрифтами. В программе The Bat! есть возможность использовать все системные шрифты Windows. Если у получателя письма установлена другая операционная система, некоторые из этих шрифтов могут отображаться у него неправильно, поэтому лучше всего писать письма шрифтами, которые доступны во всех системах – Arial, Courier New, Times New Roman.

    - с помощью этих кнопок можно выделить текст полужирным, курсивом или подчеркиванием. То же самое можно сделать с помощью комбинаций клавиш Ctrl+B, Ctrl+I и Ctrl+U, предварительно выделив нужный текст.

    - эти кнопки предназначены для выбора цвета: первая отвечает за цвет шрифта, вторая – за цвет фона для текста, третья – за общий фон письма. Выбирая общий фон письма, можно указать не только желаемый цвет, но и фоновое изображение. В качестве фона для письма может быть использовано любое изображение, хранящееся на компьютере.

    - с помощью этих кнопок можно менять выравнивание текста в HTML-письме. По умолчанию текст выравнивается по левому краю, но можно делать это по центру строки или справа, а также указать выравнивание по всей ширине строки. Выбрать один из четырех вариантов можно в процессе написания или позднее, выделив необходимый фрагмент текста.

    - вставить рисунок. Нажав на эту кнопку, можно вставить в письмо изображение, хранящееся на компьютере. После вставки его размеры можно будет изменить, растянув или сжав курсором мыши.

    - вставить ссылку. С помощью этой кнопки в письмо можно добавить ссылку на интернет-сайт, введя в появившемся окне текст заголовка и URL-адрес. Если выделить в письме уже введенный текст, а потом нажать эту кнопку, в качестве заголовка будет использован выделенный текст, останется только ввести необходимый адрес.



    - вставить горизонтальную линию. Для удобного разделения частей письма можно использовать горизонтальную линию, вставив ее с помощью этой кнопки.

    - вставить смайлик. В The Bat! есть набор смайликов, которые можно использовать в письме. Есть также опция Добавить как текст – если письмо будет просмотрено в текстовом виде, смайлик отобразится в нем в своей текстовой форме.

    - с помощью этих кнопок можно создать в письме список, маркированный или нумерованный.

    - эти кнопки предназначены для работы с таблицами. Когда таблица еще не создана, активна только первая из них – Вставить таблицу. После ее нажатия появится окно, в котором указывается число строк и колонок, а также положение таблицы в письме. С помощью остальных кнопок можно удалить колонку/строку, вставить колонку слева/справа, вставить строку выше/ниже, а также объединить ячейки.

    Работать с форматом HTML можно также с помощью разделов меню Формат и Инструменты. В них продублированы все кнопки панели Форматирование, а также доступны свойства таблицы – заполнение цветом, толщина и цвет границ, расстояние между ячейками. В это же меню можно зайти, щелкнув правой кнопкой мыши на таблице.


    0  

    Создание письма (Простой текст)

    В текстовом редакторе MicroEd есть ряд полезных функций, которые делают написание писем более удобным. Они доступны в различных пунктах меню и продублированы на верхней и нижней панелях окна редактирования письма.

    Верхняя панель

    С помощью иконок на верхней Стандартной панели, письмо можно отправить (в т.ч. указав задержку для отложенной отправки), положить в Исходящие, сохранить как черновик, сохранить и продолжить редактирование, напечатать или отменить изменения письма с момента последнего сохранения. Эти иконки дублируют основные пункты раздела меню Письмо.

    Вторая часть верхней панели называется Правка. С помощью ее иконок можно отменить последнее действие, повторить отмененное действие, вырезать или копировать выделенный фрагмент (в буфер обмена или в файл), вставить в письмо фрагмент (из буфера обмена или из файла) и прикрепить к письму файл. Вставить текст можно двумя способами – как обычный текст и как цитату. Во втором случае этот текст будет выделен другим цветом, а перед каждой его строкой появится префикс цитат – точно так же, как при ответе на письмо. Эти иконки дублируют основные пункты раздела меню Правка (прикрепить файл можно через раздел меню Инструменты).

    Третья часть верхней панели - Безопасность. С помощью ее иконок можно зашифровать и/или подписать письмо, чтобы доступ к его содержимому имели только авторизованные лица. Эти иконки дублируют основные пункты раздела меню Криптография и безопасность.

    Четвертая часть верхней панели – Поиск. С помощью иконок этой панели можно найти в письме определенный текст, найти и заменить его другим текстом, продолжить поиск либо произвести обратный поиск. Эти иконки дублируют пункты раздела меню Поиск.

    Нижняя панель

    Важно помнить, что изменения, которые вы произведете в настройках через нижнюю панель, будут действительны только для текущего письма. Для того, чтобы изменить настройки для всех писем, необходимо воспользоваться пунктом меню Свойства -> Настройка редактора писем (из главного окна программы Свойства -> Настройка с последующим выбором раздела Настройка редактора).

    Значок свидетельствует о том, что письмо еще не было изменено по сравнению с изначальным видом. Когда это происходит, цвет значка меняется на красный: .

    Цифры 3:1 обозначают текущее положение курсора. В приведенном примере курсор находится на третьей строке письма перед ее первым символом.

    Указатель Вставка означает, что печатаемый текст будет добавляться перед уже существующим. Если нажать клавишу Insert или нажать на этот указатель, появится надпись Замена, а добавляемый текст заменит существующие символы.

    Форматирование текста

    - стиль выбора. В MicroEd вы можете выбрать, как выделять части текста для копирования или форматирования, через пункт меню Правка -> Тип блока (это же меню доступно при щелчке правой кнопкой мыши на теле письма). Существует три варианта: Поток (режим по умолчанию, текст выделяется последовательно), Строки (выделяются целиком строки текста), Столбцы (выделяются вертикальные колонки текста; режим особенно полезен при работе с таблицами).

    - автоперенос. В редакторе вы можете установить максимальную длину строки письма (по умолчанию – 70 знаков). Когда вы пишете письмо, при достижении конца строки текст автоматически переносится. Изменить длину строки вы можете в Настройках редактора. Для этого необходимо установить другое значение в поле Переносить текст на … знаках.

    - автоматическое форматирование. Если эта опция включена, при добавлении текста в письмо произойдет переформатирование измененного абзаца. По умолчанию автоформатирование отключено, поскольку подходит не всем пользователям. Если вы хотите включить автоформатирование, важно помнить, что в MicroEd абзацы отделяются друг от друга пустыми строками, т.е. двойным нажатием клавиши Enter. Одиночное нажатие прервет строку и перенесет курсор на следующую, но не разорвет абзац, что впоследствии отразится на автоформатировании текста.

    - выравнивать при автоформате. Если эта опция включена, при переносе текста абзац будет выравниваться по ширине. По умолчанию эта опция отключена, как и автоматическое форматирование, с которым они взаимосвязаны.

    - автоматическая проверка орфографии. В The Bat! доступны модули проверки правописания и словари для нескольких языков, которые помогут вам избежать орфографических ошибок в письме. Помимо автоматической проверки, есть и другие способы следить за орфографией – через раздел меню Орфография в любой момент можно Проверить весь текст (горячая клавиша F4), Проверить текст от курсора (комбинация клавиш Shift+F4) или Проверить перед отправкой/записью.

    - словари проверки орфографии. Щелкнув на этой области, вы можете выбрать языки, для которых будет осуществляться проверка. Поиск слов будет происходить во всех выбранных словарях, поэтому даже если в вашем письме присутствует текст на нескольких языках, проверка пройдет успешно.

    - приоритет письма. Вы можете указать срочность письма. По умолчанию приоритет всех писем нормальный, но его можно сделать высоким или низким .

    - подтверждение доставки. Если эта опция включена, вместе с письмом будет отправлен запрос о подтверждении доставки. Когда письмо попадет к получателю, вам придет уведомление. Важно помнить, что доставка и прочтение – это не одно и тоже: если вы хотите быть уверены в том, что получатель прочел письмо, следует запрашивать подтверждение прочтения. Сделать это можно, нажав на значок .

    - активный почтовый ящик. Здесь вы можете выбрать, какой из ваших почтовых ящиков будет использован для отправки письма.

    - отложенная отправка. The Bat! может отослать ваше письмо с задержкой, на тот случай, если вы захотите что-нибудь в нем изменить. По умолчанию письма отправляются немедленно, но можно отложить отправку на 15 минут, 1 час либо любой другой интервал по вашему выбору.

    - используемый формат письма (текстовый или HTML).

    - текущий набор символов (кодировка). Наборы символов предназначены для поддержки разнообразных национальных кодировок. Например, для России в письмах на русском языке наиболее часто используются таблицы Cyrillic (Windows) – стандартная – и Cyrillic KOI8-R – альтернативная. Если вы напишете письмо в нестандартной или некорректной кодировке, то получатель не сможет прочитать его. Изменение набора символов может понадобиться, если вы пишете письмо на другом языке.

    - настройки шифрования и безопасности. Здесь вы можете выбрать, каким образом будет зашифровано создаваемое письмо – с помощью S/MIME или OpenPGP. Даже если вы измените значение в этом поле, шифрование не произойдет без нажатия иконок Зашифровать перед отправкой или Подписать перед отправкой . О том, активны ли эти опции, говорят значки и на нижней панели письма.

    Меню

    В MicroEd есть ряд полезных функций, не представленных на панелях инструментов. Например, через пункт меню Формат -> Выравнивание вы можете выбрать, как будет выровнен тот или иной абзац: по левому краю (комбинация клавиш Alt+L), по правому краю (Alt+R), по центру (Alt+C) либо по всей ширине строки (Alt+J).

    Через меню Инструменты вы можете вставить в текст письма дату и время, изменить регистр введенного текста, а также вставить Быстрый шаблон.

    В меню Вид вы можете настраивать панели инструментов, убирая ненужные иконки или добавляя новые для своего удобства.


    0  

    Формат письма

    С помощью The Bat! можно создавать письма в форматах текст, HTML или комбинируя их. Кроме того, программа предлагает вам ряд возможностей для автоматического создания письма целиком или определенной его части – шаблоны, макросы, правила сортировки.

    Простые текстовые письма удобнее всего создавать с помощью встроенного редактора MicroEd. Такие письма можно прочитать, используя любую почтовую программу или почтовый сайт. В редакторе MicroEd доступны основные опции работы с текстом. Курсор при написании письма можно устанавливать в любом месте – так, например, можно печатать абзацы с отступом или создавать таблицы.

    Если вас не устраивает MicroEd, The Bat! дает возможность использовать текстовый редактор, встроенный в Windows. Главные различия этих механизмов заключаются в работе с цитатами и форматировании текста.

    Если вы хотите написать письмо с несколькими шрифтами, изображениями, таблицами и другими объектами, воспользуйтесь форматом HTML или смешанным форматом HTML/Простой текст. В редакторе появится дополнительная панель инструментов для удобной работы со шрифтами и объектами. При использовании смешанного формата письмо делится на HTML и текстовую часть. Это делается на тот крайне редкий случай, если почтовый клиент получателя не может работать с HTML. Кроме того, некоторые инструменты автоматической обработки писем не воспринимают текст в формате HTML и работают только с обычным текстом.

    По умолчанию The Bat! использует для создания писем редактор MicroEd. Это можно изменить через окно настройки The Bat! (Свойства -> Настройка), выбрав в разделе Редактор и Просмотр писем нужный вариант в меню Редактор текста по умолчанию:





    В этом же окне можно выбрать способы просмотра различных форматов входящей почты. По умолчанию опция Отвечать на HTML текстом не активна. Если необходимо создавать ответы на HTML письма, используя текстовый редактор, установите соответствующую галочку.

    Если вы хотите использовать для создания писем MicroEd, но иногда переключаться на HTML-редактор, в этом случае письмо следует создавать через пункт меню Свойства -> Формат письма.


    0