The Bat! Hilfe

Ordner (6)
Vorlagen (8)
Makros (12)

Datenschutz und Sicherheit

  • Sicherheitstoken
  • S/MIME
  • OpenPGP
  • Anti-Junk-Plugins
  • Antivirus-Plugins
  • Anlagensicherheit
  • Datenschutz und Sicherheit

  • Sicherheitstoken

    Ein Sicherheitstoken ist eine leistungsstarke, tragbare Zwei-Faktor-Authentifizierungs-Hardware, die für zusätzliche Sicherheit sorgt. Das Token enthält eine 64-bit Seriennummer, die jedes Token eindeutig kennzeichnet.


    Token Treiber installieren

    Um das Token für Ihre Nachrichtendatenbank oder für die POP3/SMTP Authentifikation zu verwenden, müssen Sie zuerst den Treiber installieren und das Token aktivieren.

    Anmerkung: Verwenden Sie Aladdin eToken, können Sie den Treiber hier herunterladen: http://www.aladdin-rd.ru/support/downloads/etoken/
    Um den Treiber für Rainbow iKey1000 herunterzuladen, folgen Sie dem Link: http://www.safenet-inc.com/support_and_downloads/download_drivers/ikey_drivers.aspx


    Persönliche Identifikationsnummer
    (PIN) ändern

    Nachdem Sie den Treiber installiert haben, stecken Sie das Token in den USB-Anschluss und öffnen Sie seine Eigenschaften (eToken Properties). Wählen Sie eToken-Kennwort ändern und geben Sie die PIN ein (PIN für eToken - 1234567890, Anwender PIN für iKey – 12345678, Administrator PIN für iKey - rainbow). Definieren Sie das gewünschte Passwort, das aus 5-10 Zeichen bestehen muss (Ziffern, Buchstaben und Satzzeichen).


    Token Manager und Token Activation

    Bevor Sie das Token mit The Bat! Professional verwenden können, müssen Sie:
    1. das Token mithilfe Token Activation aktivieren
    2. die ID für die Nachrichtendatenbankverschlüsselung mithilfe von Token Manager auf das Token kopieren
    Laden Sie den Token Manager mit Token Activation von unserer Webseite herunter und starten Sie tokenmgr.msi, um sie zu installieren.


    Token aktivieren

    Um das Token zu aktivieren, stecken Sie es in Ihren USB-Anschluss und starten Sie Token Activation über Start -> Alle Programme -> The Bat! E-Mail -> Token Activation Utility. Wählen Sie das Token aus und klicken Sie auf ОК.



    Geben Sie die Bestellnummer für The Bat! Professional ins Feld Order Number ein und klicken Sie auf Submit (Übertragen).



    Die Bestellnummer für The Bat! Professional erhalten Sie, wenn Sie die Lizenz kaufen.



    Klicken Sie auf den Button Fetch Key , um den Webbrowser zu starten und unsere Webseite mit dem Aktivierungscode zu öffnen. Kopieren Sie den Code, fügen Sie ihn ins Feld Token Activation Key ein und klicken Sie auf den Button Activate, um das Token zu aktivieren. Geben Sie das Passwort (PIN) ein.




    ID für Nachrichtendatenbankverschlüsselung

    Um die ID für die Nachrichtendatenbankverschlüsselung auf das Token zu kopieren, starten Sie den Token Manager über Start -> Alle Programme -> The Bat! E-Mail -> Token Manager. Beim ersten Start des Token Managers müssen Sie das Master-Passwort eingeben und bestätigen.



    Klicken Sie den Button Browse an, wählen Sie das Token und klicken Sie auf ОК. Geben Sie das Passwort (PIN) ein. Wenn das Token ausgewählt wird, werden sein Name und seine Seriennummer im Feld Selected Token angezeigt.

    Klicken Sie auf New ID.



    Geben Sie den Benutzernamen ins Feld User Name ein. Der Benutzername kann kleine lateinische Buchstaben, Unterstriche, Bindestriche und Punkte beinhalten. Man darf keine großen Buchstaben, Leerzeichen und Sonderzeichen verwenden. Der Name muss von 1 bis 12 Zeichen lang sein. Füllen Sie das Feld Description aus – hier gibt es keine Einschränkungen hinsichtlich Zeichen und Länge.



    Wählen Sie die ID und klicken Sie auf Copy ID to Token.


    The Bat! Professional installieren

    Installieren Sie The Bat! Professional, aktivieren Sie die Option Nachrichtendatenbanken und Adressbücher „on-the-fly“ verschlüsseln beim ersten Programmstart und wählen Sie das Token, das Sie für den Datenschutz verwenden möchten.



    Weisen Sie dem Programm die Token ID zu. Jede ID besteht aus 3 Komponenten: dem 128-Bit Kodierschlüssel, dem Anwendernamen und einer kurzen Beschreibung. Die IDs werden jeweils auf dem Token gespeichert und beim Start von The Bat! Professional ausgelesen.

    Um dem Programm eine ID zuzuweisen, wählen Sie das Token und die gespeicherte ID aus. Beachten Sie, dass das Token mindestens eine ID beinhalten muss. Die ausgewählte ID wird The Bat! zugewiesen und für die weitere Installation verwendet. Danach kann man dem Programm keine andere ID mehr zuweisen. Der 128-Bit Kodierschlüssel der zugewiesenen ID wird für die Echtzeit-Verschlüsselung aller The Bat! Operationen verwendet.

    Kann beim ersten Programmstart die Option Nachrichtendatenbanken und Adressbücher „on-the-fly“ verschlüsseln nicht ausgewählt werden, bedeutet das, dass Sie entweder die Home Edition verwenden, die keine Echtzeit-Verschlüsselung unterstützt, oder dass das Programm bereits auf diesem Rechner installiert war. Im zweiten Fall müssen Sie die Datensicherung vornehmen und das Programm deinstallieren, auch den Schlüssel "RIT" in der Registrierung "HKEY_CURRENT_USER\Software\...\".


    Token für POP3/SMTP-Authentifikation verwenden

    Klicken Sie auf den Button Authentifikation im Bereich „Senden-SMTP“ oder „Empfangen – POP3/IMAP4“ im Menü Konto -> Eigenschaften -> Transport. Sind Token-Treiber und API auf dem Rechner installiert, können Sie die Option Token MD-5 CRAM-HMAC Abfrage/Rückmeldung im Fenster „Nachrichtenempfang (POP3/IMAP) Authentifikation“ und die Option Passwort auf Token speichern unter „Erweiterte SMTP-Optionen“ aktivieren.

    Wenn Sie das Häkchen bei diesen Optionen setzen, werden zwei neue Optionen-Gruppen angezeigt:

    Die erste Gruppe zeigt die Seriennummer und den Namen des Tokens an, das Sie für Ihre POP3 oder SMTP-Authentifikation verwenden. Die Seriennummer des ausgewählten Tokens wird in der Konfigurationsdatei des Kontos gespeichert. The Bat! wird eine Token mit einer anderen Seriennummer nicht für die Authentifikation verwenden, außer wenn Sie auf Durchsuchen klicken und ein anderes Token auswählen. Damit sein Name angezeigt wird, muss das Token eingesteckt und verfügbar sein (es darf nicht von anderen Anwendungen benutzt werden).

    Das Passwort können Sie setzen, ändern oder löschen. Verwenden Sie dafür die einsprechenden Buttons.


    0  

    S/MIME

    Zertifikate verwalten
    Interne Implementierung von S/MIME
    Microsoft CryptoAPI
    Digitale Signatur
    Nachrichten verschlüsseln
    Nachrichten entschlüsseln
    Standard S/MIME

    Zertifikate verwalten

    Zertifikat erhalten

    Die Zertifikate werden normalerweise von einer Zertifizierungsstelle ausgestellt. In The Bat! können Sie auch ein selbst-signiertes Zertifikat erstellen. Um das Zertifikat zu erstellen, klicken Sie auf Persönliche Zertifikate im Menü Konto -> Eigenschaften -> Allgemein.

    Klicken Sie im daraufhin geöffneten Fenster auf den Button Neues Zertifikat. Um den Prozess der Zertifikaterstellung zu beenden, geben Sie das Passwort ein und klicken auf Bestätigen.



    Der Empfänger des selbst-signierten Zertifikats muss dieses Zertifikat in den Zertifikatspeicher einfügen. Das erstellte Zertifikat können Sie auch bei der Zertifizierungsstelle beglaubigen.

    Es ist nicht notwendig, das Zertifikat in The Bat! zu erstellen – man kann das Zertifikat auch über die Zertifizierungsstelle erhalten und dann in The Bat! importieren.


    Zertifikat ansehen

    Um das Zertifikat anzusehen, öffnen Sie das Adressbuch (Tastenkürzel F8), wählen Sie den Kontakt und den Punkt Eigenschaften im Menü Bearbeiten. Das Zertifikat können Sie im Reiter Zertifikate ansehen.

    Eigene Zertifikate können Sie über das Menü Konto -> Eigenschaften -> Allgemein -> Persönliche Zertifikate anzeigen. Wählen Sie das Zertifikat aus und klicken Sie auf Ansicht.

    Im Abschnitt Details finden Sie die Version, Seriennummer, Daten über den verwendeten Signaturalgorithmus, den Gültigkeitszeitraum, den Aussteller und den Zertifikatinhaber finden.

    Im Abschnitt Zertifizierungspfad kann man alle Zertifikate inklusive Zertifizierungsstelle, die mit diesem Zertifikat verknüpft ist, ansehen.


    Zertifikat exportieren

    Wenn Sie die interne Implementierung von S/MIME verwenden, können Sie das Zertifikat in eine Datei exportieren. Auf diese Weise können Sie das Zertifikat zum Beispiel in ein anderes Programm importieren.

    Öffnen Sie das Adressbuch (Tastenkürzel F8), wählen Sie den Kontakt und den Punkt Eigenschaften im Menü Bearbeiten. Im Abschnitt Zertifikate wählen Sie das Zertifikat und klicken auf Zertifikat-Export. Das Zertifikat können Sie in einem der folgenden Formate exportieren:



    • PKCS #12-Zertifikate (.PFX) - Bei dieser Option kann man eine Gruppe von Zertifikaten mit ihren privaten Schlüsseln, die mit denselben Passwörtern wie in The Bat! verschlüsselt werden, exportieren. Die Zertifikate selbst werden nicht verschlüsselt. Entspricht PKCS 12 v1.0: Personal Information Exchange Syntax (von RSA Laboratories entwickelt)
    • PKCS #7-Zertifikate (.P7B) - Bei dieser Option kann man eine Gruppe von Zertifikaten in die Datei exportieren, die auf dem Format der signierten Nachricht basiert (die Nachricht enthält keinen Text und keine Signatur, sondern nur die angehängten Zertifikate). Sie enthält nur Zertifikate, keine privaten Schlüssel. Das ist das meist verbreitete Format. Entspricht RFC- 2630 (Cryptographic Message Syntax).
    • DER-binär kodiertes X.509 (.CER) - In dieses Format kann man nur Zertifikate ohne private Schlüssel exportieren. Die Datei enthält ein X.509-Zertifikat, das entsprechend dem Algorithmus DER kodiert wird. Das Zertifikat selbst wird nicht verschlüsselt. Enthält das Zertifikat den privaten Schlüssel, kann er unverschlüsselt in eine binäre Datei entsprechend PKCS#1 DER-encoded RSA exportiert werden. Hinweis: Nicht alle Programme unterstützen dieses Format.
    • Base-64-kodiertes X.509 (.CER). Das Format basiert auf der DER-kodierten binären Datei X.509 und ist Base-64-kodiert. Die Datei enthält nur sichtbare Zeichen und kann einer Nachricht oder Webseite hinzugefügt werden. Dieses Format ist weit verbreitet. Private Schlüssel können in Text-Dateien exportiert werden.
    Beim Export kann man folgende Optionen aktivieren:
    • Möglichst alle Zertifikate im Zertifikatspfad mit einschließen

    Aktivieren Sie diese Option, damit das Zertifikat geprüft werden kann. Dies ist nur dann möglich, wenn alle verknüpften Zertifikate inklusive Zertifizierungsstelle vorhanden sind.

    Hinweis: Diese Option funktioniert nur mit Formaten, in die mehrere Zertifikate exportiert werden können.
    • Private Schlüssel ebenfalls exportieren
    Diese Option kann man bei PKCS #7-Zertifikaten (.P7B) aktivieren. Möchten Sie das Zertifikat exportieren, um es Ihren E-Mail-Partnern zuzusenden und mit diesem Zertifikat verschlüsselte Nachrichten zu bekommen, sollten Sie den privaten Schlüssel nicht exportieren.


    Zertifikat importieren

    Verfahren 1
    Öffnen Sie die Nachricht mit dem Zertifikat und klicken Sie auf das Icon rechts im Kopfzeilenbereich, um es zu sehen. Wählen Sie das Zertifikat aus und klicken Sie auf Ansicht. Im Abschnitt Allgemein klicken Sie auf Zum Adressbuch hinzufügen, um das Zertifikat zu importieren. Wenn Sie das nächste Mal eine mit diesem Zertifikat signierte Nachricht nächstes Mal erhalten, taucht im Kopfzeilenbereich das Icon auf. Dies bedeutet, das Zertifikat ist gültig.

    Verfahren 2

    Das Zertifikat kann man direkt in das Adressbuch importieren. Wählen Sie den Kontakt im Adressbuch und greifen Sie seine auf Eigenschaften zu – klicken Sie dafür zweimal auf den Kontakt oder wählen Sie den Punkt Eigenschaften im Menü Bearbeiten. Im Abschnitt Zertifikate klicken Sie auf Zertifikat-Import und wählen Sie die Datei, die das Zertifikat enthält.


    Interne Implementierung von S/MIME

    Um die interne Implementierung von S/MIME zu verwenden, wählen Sie die Option Interne Implementierung im Menü Optionen -> S/MIME und TLS.

    Der Unterschied zwischen interner Implementierung und Microsoft CryptoAPI besteht darin, dass im ersten Fall kein externer Programmcode verwendet wird. Das bedeutet, die interne Implementierung funktioniert in verschiedenen Windows Versionen gleich. Wenn Sie die interne Implementierung verwenden, können Sie zwischen folgenden Optionen auswählen.



    Immer mit Absender-Zertifikat verschlüsseln
    Aktivieren Sie diese Option, um Nachrichten mit Ihrem öffentlichen Schlüssel zu verschlüsseln – dann haben Sie die Möglichkeit, die ausgehenden Nachrichten zu entschlüsseln und zu lesen.

    Daten vor Verschlüsselung komprimieren
    Die Komprimierung reduziert die Nachrichtengröße und erhöht die Stabilität im Fall von Angriffen.

    Vorsicht: Komprimierung wird von anderen S/MIME Implementierungen in anderen E-Mail-Programmen möglicherweise nicht unterstützt. So unterstützt Microsoft CryptoAPI die Komprimierung nicht.

    Mantra-/Schlüssel-Caching für
    Ist diese Option aktiviert, wird das Passwort für das Zertifikat für eine bestimmte Zeit zwischengespeichert. Auf diese Weise brauchen Sie es nicht wieder einzugeben.

    Verschlüsselungsalgorithmus. Wählen Sie einen Algorithmus aus dem Dropdownmenü aus.

    Signatur-Hash-Algorithmus. Algorithmus, der für Hashing verwendet wird. Der voreingestellte Algorithmus SHA-1 ist weit verbreitet und gewährleistet hohe Sicherheit. Wird er von Ihren Empfängern nicht unterstützt, können Sie MD-5 auswählen.

    Im Feld Datei mit Zufallswerten wird der Pfad zur Datei angezeigt, in der die Zufallswerte für die Schlüsselerstellung gespeichert werden.

    Man kann die Option Benutzer Zeitstempel-Server für Digitale Signaturen aktivieren, um die Zeitstempel zur Signatur hinzuzufügen.


    Microsoft CryptoAPI

    Microsoft CryptoAPI gehört zu Microsoft Windows. Nähere Information über CryptoAPI kann man in Windows Dokumentationen finden.



    Immer mit Absender-Zertifikat verschlüsseln
    Aktivieren Sie diese Option, um Nachrichten mit Ihrem öffentlichen Schlüssel zu verschlüsseln – dann haben Sie die Möglichkeit, die ausgehenden Nachrichten zu entschlüsseln und zu lesen.

    Im Dropdownmenü Kryptographie Service Provider sehen Sie alle vorhanden Kryptographie Service Provider.
    Anmerkung: Wenn Sie einen Kryptographie Service Provider aus der Liste wählen, wird The Bat! nur ihn verwenden. In diesem Fall wird automatisch der Provider verwendet, der am besten zum Algorithmus, Schlüssel- oder Zertifikatstyp passt.

    Abhängig vom Kryptographie Service Provider können Sie einen bestimmten Verschlüsselungsalgorithmus und Signatur-Hash-Algorithmus auswählen.
    Anmerkung: Bei Microsoft CryptoAPI fügt The Bat! nur eine Signatur zur Nachricht hinzu.

    Ist die Option Verknüpfung zwischen E-Mailadressen und Zertifikaten für Signierung beibehalten aktiviert, merkt sich The Bat!, welches Zertifikat für die Signierfunktion verwendet wurde.

    Wenn Sie die Option Verknüpfung zwischen E-Mailadressen und Zertifikaten für Verschlüsselung beibehalten aktivieren, merkt sich das Programm, welches Zertifikat für die Verschlüsselung verwendet wurde.


    Digitale Signatur

    Die Aufgabe der S/MIME Signatur ist es sicherzustellen, dass der Absender keine falsche Identität vortäuscht. Auf diese Weise können Veränderungen an E-Mails festgestellt werden. The Bat! vermerkt solcherart gefälschte Nachrichten.

    Nachrichten manuell signieren
    Aktivieren Sie die Option S/MIME aktivieren im Menü Sicherheit im Nachrichteneditor. Um die Nachricht zu signieren, aktivieren Sie die Option Nachricht digital signieren oder klicken Sie auf das Icon in der Symbolleiste Sicherheit.

    Nachrichten automatisch signieren
    The Bat! kann Nachrichten automatisch signieren. Aktivieren Sie hierzu die Optionen S/MIME aktivieren und Nachricht digital signieren im Menü Konto -> Eigenschaften -> Optionen.
    Tipp: Sie können das Makro %SIGNCOMPLETE in Ihren Vorlagen verwenden – dabei werden Nachrichten vor dem Senden automatisch signiert.

    Signatur überprüfen

    Signierte Nachrichten werden mit dem Symbol in der Nachrichtenliste ausgezeichnet. Um die Signatur der Nachricht zu prüfen, wählen Sie die Option Signatur überprüfen im Menü Hilfsmittel -> Sicherheit (Tastenkombination Umschalt+Strg+C).

    The Bat! prüft S/MIME Signaturen automatisch: Ist eine Signatur gültig, wird das Icon im Kopfzeilenbereich eingeblendet.


    Nachrichten verschlüsseln

    Durch die Verschlüsselungsfunktion können Sie die Sicherheit vertraulicher E-Mails gewährleisten. Nur die E-Mail-Partner, deren öffentliche Schlüssel zur Verschlüsselung einer Nachricht verwendet wurden, können diese Nachricht lesen. Um die Nachricht zu verschlüsseln, müssen Sie zuerst das Zertifikat des Empfängers ins Programm importieren.

    Vorsicht: In manchen Ländern kann das Verschlüsseln von E-Mails verboten sein.

    Nachrichten manuell verschlüsseln
    Aktivieren Sie im Nachrichteneditor die Option S/MIME aktivieren über das Menü Sicherheit. Wählen Sie den Punkt Nachricht verschlüsseln aus oder klicken Sie auf das Icon in der Symbolleiste Sicherheit. Nun können Sie Ihre Nachricht weiterbearbeiten – sie wird vor dem Senden verschlüsselt.

    Nachrichten automatisch verschlüsseln

    Sie können auch die automatische Verschlüsselung Ihrer Nachrichten definieren. Aktivieren Sie dafür die Optionen S/MIME aktivieren und Nachricht verschlüsseln im Menü Konto -> Eigenschaften -> Optionen.

    Tipp: Sie können das Makro %ENCRYPTCOMPLETE in Ihre Vorlagen einbauen – so werden die Nachrichten automatisch vor dem Senden verschlüsselt.

    Anmerkung: Sie können Nachrichten auch mit Ihrem Zertifikat verschlüsseln. Bei der normalen Verschlüsselung besteht der Nachteil, dass Sie die Nachrichten, die Sie einmal versandt haben, nicht mehr lesen können.


    Nachrichten entschlüsseln

    Um die Nachricht zu entschlüsseln, markieren Sie sie und klicken im Menü Hilfsmittel -> Sicherheit auf Entschlüsseln (Tastenkombination Umschalt+Strg+D).

    Die entschlüsselte Nachricht wird aus Sicherheitsgründen nicht automatisch in der Nachrichtendatendatenbank gespeichert. Jedes Mal wenn man die verschlüsselte Nachricht lesen möchte, sollte man sie wieder entschlüsseln. Falls nötig, können Sie die Nachricht entschlüsseln und abspeichern (Tastenkombination Umschalt+Strg+G). Wählen Sie dafür die entsprechende Option im Menü Hilfsmittel -> Sicherheit (Tastenkombination Umschalt+Strg+G).

    Anmerkung: The Bat! prüft die Signaturen automatisch.

    Standard S/MIME

    Standard S/MIME sichert den Nachrichtenaustauch gemäß:
    1. RFC2632 S/MIME Version 3 Certificate Handling
    2. RFC2633 S/MIME Version 3 Message Specification
    3. RFC2634 Enhanced Security Services for S/MIME
    Zertifikate werden normalerweise von einer Zertifizierungsstelle ausgestellt. Das Zertifikat enthält Namen, öffentlichen Schlüssel, Seriennummer, Gültigkeitszeitraum, Namen und Signatur des Ausstellers.


    0  

    OpenPGP

    PGP-Version auswählen
    OpenPGP-Schlüsselverwaltung
    Öffentliche Schlüssel importieren
    Interne OpenPGP-Implementierung einstellen
    Nachrichten verschlüsseln
    Nachrichten entschlüsseln
    Digitale Signatur
    Standard PGP/MIME

    In The Bat! können Sie OpenPGP zum Verschlüsseln und Signieren von Nachrichten verwenden. Die Verschlüsselung schützt die Privatsphäre im Internet und verhindert, dass Ihre Nachrichten von Dritten gelesen und geändert werden können. Die interne PGP-Implementierung stimmt mit den Standards RFC-1991 überein. Außerdem kann man die externen PGP-Programme bis Version 10 sowie GnuPG in The Bat! einbinden.


    PGP-Version auswählen

    Bevor Sie die PGP-Version auswählen, müssen Sie sie herunterladen, installieren und einstellen.

    Um das Programm zu integrieren, starten Sie The Bat! und wählen im Menü Optionen -> OpenPGP -> Version auswählen die PGP-Version aus.


    • Interne (RFC 1991) – Verwendet die interne OpenPGP Version.
    • PGP Kommandozeile (2.6.3, 6.0.x+) – Verwendet die klassische Version 2.6.3 oder eine spätere Version.
    • PGP 5.5.x Plugin - The Bat! braucht das Plugin PGP 5.5.x, um auf die Einstellungen zuzugreifen.
    • PGP 6.0.x/6.5.x Plugin - The Bat! braucht das Plugin PGP 6.0.x/6.5.x, um auf die Einstellungen zuzugreifen.
    • GNU Privacy Guard (GPG) – Die GnuPG-Anwendung muss installiert sein.
    • PGP 5, 6, 7, 8, 9, 10 (built-in support) - The Bat! greift direkt auf die Einstellungen externer OpenPGP-Anwendungen zu.
    Der sachgemäße Datenschutz elektronischer Nachrichten mit PGP-Schlüsseln erfordert eingehende Kenntnisse über die PGP-Verschlüsselung von Nachrichten. Um keine Fehler zu machen, die Sicherheit und Vertraulichkeit Ihrer Nachrichten gefährden könnten, sollten Sie sich mit der PGP-Verschlüsselung eingehend vertraut machen.

    OpenPGP-Schlüsselverwaltung

    Um Nachrichten zu verschlüsseln oder zu signieren, sollte man zuerst ein Schlüsselpaar erzeugen, das aus einem öffentlichen und einem privaten Schlüssel besteht. Über den öffentlichen Schlüssel sollten all Ihre E-Mail-Partner verfügen, mit denen Sie sichere Nachrichten austauschen wollen. Ihr privater Schlüssel muss absolut geheim bleiben.

    Um das Schlüsselpaar zu erzeugen, wählen Sie den Punkt Schlüsselverwaltung im Menü Optionen -> OpenPGP. Im Menü Schlüssel klicken Sie auf Neuer Schlüssel. Es öffnet sich das Fenster OpenPGP-Schlüsselverwaltung. Folgen Sie der Anweisungen, um das Schlüsselpaar zu erzeugen. Sie werden aufgefordert, Ihren vollständigen Namen und Ihre E-Mail-Adresse einzugeben. Beide Informationen werden diesen Schlüsseln zugewiesen. Bestimmen Sie auch die Größe des Schlüsselpaars. Falls nötig, legen Sie das Ablaufdatum fest. Ihr privater Schlüssel wird mit einem Kennsatz geschützt, den Sie festlegen müssen, bevor die Schlüssel erzeugt werden können. Danach können Sie Ihre Nachrichten nur nach Eingabe dieses Kennsatzes entschlüsseln.

    Nachdem das Schlüsselpaar erzeugt wird,wird es in der Schlüsselliste angezeigt.



    Wählen Sie Ihren öffentlichen Schlüssel (oder das Schlüsselpaar) aus und klicken Sie im Menü Schlüssel auf Exportieren (Tastenkürzel F3), um den öffentlichen Schlüssel zu exportieren. Den privaten Schlüssel dürfen Sie nicht exportieren. Wählen Sie einen Namen für die Datei aus, in der Ihr Schlüssel gespeichert wird. Stellen Sie Ihren öffentlichen Schlüssel all Ihre E-Mail-Partnern zur Verfügung. Mit ihm können Sie künftig an Sie gerichtete Nachrichten verschlüsseln. Diese verschlüsselten Nachricht können nur Sie mit Ihrem privaten Schlüssel entschlüsseln. Den öffentlichen Schlüssel kann man in einer elektronischen Nachricht als Anlage oder im Text der Nachricht senden.

    Um die öffentlichen Schlüssel Ihrer E-Mail-Partner zu importieren, wählen Sie den Punkt Importieren im Menü Schlüssel (Tastenkürzel F2) aus. Verwenden Sie diese Schlüssel, um Nachrichten an Ihre Adressaten zu verschlüsseln.

    Die Schlüsseleigenschaften können Sie über das Menü Schlüssel bearbeiten (Tastenkürzel Eingabe). In diesem Menü kann man das Passwort für den privaten Schlüssel ändern.

    Sie können einen Ihrer Schlüssel als Standardschlüssel setzen – wählen Sie ihn aus und klicken Sie auf Als Standardschlüssel setzen im Menü Schlüssel (Tastenkombination Alt+D) oder im Kontextmenü. Ist im Menü Optionen -> OpenPGP -> Einstellungen die Option Immer mit Standardschlüssel verschlüsseln aktiviert, werden die Nachrichten mit Ihrem Schlüssel verschlüsselt. So haben Sie die Möglichkeit, ausgehende verschlüsselte Nachrichten zu entschlüsseln. Sonst können nur Empfänger mit privaten Schlüsseln diese Nachrichten entschlüsseln.


    Öffentliche Schlüssel importieren

    Die öffentlichen Schlüssel können als ASCII-Text verteilt und als Text in Nachrichten integriert werden. So kann eine Nachricht mit dem öffentlichen Schlüssel aussehen:

    Hallo Stefan,
    Mein öffentlicher Schlüssel:
    -----BEGIN PGP PUBLIC KEY BLOCK-----
    Version: 2.6.3i
    mQBtAzPHTM0AAAEDAKCJ5/hM+qpxHaa4wFumqU2DEV4KfkKe5hkkfS6knTtn0rnD Zm/90txo+29gOFARBL8ynIpGA7fUgmNG13mprN9q/9xrtH4gg6jV/cYJ3ZtnKN9B sfw7QLKsW3r6eMYGsQAFEbQiU3RlZmFuIFRhbnVya292IDxzdGVmQHJpdGxhYnMu Y29tPokAdQMFEDPHTM2sW3r6eMYGsQEBft0DAIi04Yya7Q5ZZAtz2K4bKHitMBFV j1g0Vmr87Cr5qZYgGBzbNasyFwUuFqwqEuiwnLVNSpPiK8QsJTff6Ky9hqMUiZaL ENOzJ5f9GKw0pmMio7rOlKRE8Szbl6RkpeCUQw==
    =u13G
    -----END PGP PUBLIC KEY BLOCK-----
    Viele Grüße,
    Johannes

    Um den öffentlichen OpenPGP Schlüssel zu importieren, wählen Sie die Option Schlüssel/Zertifikat importieren im Menü Hilfsmittel -> Sicherheit. Sie können auch das Icon auf der Symbolleiste anklicken, um den öffentlichen Schlüssel aus der Nachricht zu importieren.  


    Interne OpenPGP-Implementierung einstellen

    Auf die Einstellungen der internen OpenPGP Implementierung kann man über das Menü Optionen -> OpenPGP zugreifen.



    Aktivieren Sie die Option Immer mit Standardschlüssel verschlüsseln, um Nachrichten mit Ihrem öffentlichen Schlüssel zu verschlüsseln – dann haben Sie die Möglichkeit, die ausgehenden Nachrichten zu entschlüsseln und zu lesen.

    Die Option Daten vor Verschlüsselung komprimieren ist voreingestellt aktiviert.

    Aktivieren Sie die Optionen Passphrase-Caching für Entschlüsselung/Signatur und stellen Sie eine Zeit ein, damit das Programm Ihren privaten Schlüssel zwischenspeichert – dies erleichtert das Entschlüsseln und Signieren Ihrer Nachrichten.

    Bei Bedarf können Sie einen Kommentar hinzufügen (z.B. Ihre OpenPGP Version).

    Im Abschnitt Dateien werden die Pfade zu Dateien mit öffentlichen und privaten Schlüsseln sowie zu einer Datei mit Zufallswerten angezeigt.


    Nachrichten verschlüsseln

    Durch die Verschlüsselung gewährleisten Sie die Vertraulichkeit Ihrer Nachrichten. Nur die E-Mail-Partner, mit deren öffentlichen Schlüsseln Sie die Nachrichten verschlüsseln, können diese Nachrichten lesen.

    Vorsicht: In manchen Ländern kann eine Verschlüsselung verboten sein.
    Vorsicht: Obwohl der Verschlüsselungsalgorithmus, der in OpenPGP verwendet wird, sicher ist, besteht die Gefahr, dass der private Schlüssel kompromittiert wird.

    Nachrichten manuell verschlüsseln

    Verfahren 1
    Aktivieren Sie im Nachrichteneditor die Option OpenPGP aktivieren über das Menü Sicherheit. Wählen Sie in diesem Menü den Punkt Nachricht verschlüsseln oder klicken Sie auf das Icon in der Symbolleiste Sicherheit. Nachdem Sie die Option aktiviert haben, können Sie die Nachricht weiterbearbeiten – sie wird vor dem Senden verschlüsselt.

    Verfahren 2
    Aktivieren Sie im Nachrichteneditor die Option OpenPGP aktivieren über das Menü Sicherheit und wählen Sie eine der Optionen – Ganzen Text verschlüsseln oder Ganzen Text signieren und verschlüsseln. Im zweiten Fall wird die Nachricht auch signiert.

    Nachrichten automatisch verschlüsseln

    Sie können auch eine automatische Verschlüsselung der Nachrichten einstellen. Aktivieren Sie dafür die Optionen OpenPGP aktivieren und Nachricht verschlüsseln im Menü Konto -> Eigenschaften -> Optionen.

    Tipp: Sie können das Makro %ENCRYPTCOMPLETE in Ihre Vorlagen einbauen – so werden die Nachrichten automatisch vor dem Senden verschlüsselt.


    Nachrichten entschlüsseln

    Um Nachrichten zu entschlüsseln, markieren Sie sie und klicken im Menü Hilfsmittel -> Sicherheit auf Entschlüsseln (Tastenkombination Umschalt+Strg+D).

    Die entschlüsselte Nachricht wird aus Sicherheitsgründen in der Nachrichtendatendatenbank nicht automatisch gespeichert. Wenn man die verschlüsselte Nachricht lesen möchte, muss man sie jedes Mal erneut entschlüsseln. Falls nötig, können Sie die Nachricht entschlüsseln und die entschlüsselte Nachricht speichern (Tastenkombination Umschalt+Strg+G) – wählen Sie dafür die entsprechende Option im Menü Hilfsmittel -> Sicherheit (Tastenkombination Umschalt+Strg+G).

    Anmerkung: The Bat! prüft die Signatur automatisch, falls eine vorhanden ist.


    Digitale Signatur

    Mit der PGP-Signatur lässt sich die Echtheit seines Absenders prüfen. Um den Empfängern Ihrer Nachrichten die Gewissheit zu geben, dass die Nachrichten tatsächlich von Ihrer Emailadresse stammen, sollten Sie Ihre Nachrichten signieren.

    Nachrichten manuell signieren

    Verfahren 1
    Im Nachrichteneditor aktivieren Sie die Option OpenPGP aktivieren über das Menü Sicherheit. Wählen Sie in diesem Menü den Punkt Nachricht digital signieren oder klicken Sie auf das Icon in der Symbolleiste Sicherheit.

    Verfahren 2

    Im Nachrichteneditor aktivieren Sie die Option OpenPGP aktivieren über das Menü Sicherheit und wählen Sie eine der Optionen – Block signieren oder Ganzen Text signieren.

    Nachrichten automatisch signieren

    Um die Nachrichten automatisch zu signieren, aktivieren Sie die Optionen OpenPGP aktivieren und Nachricht digital signieren im Menü Konto -> Eigenschaften -> Optionen.

    Tipp: Sie können das Makro %SIGNCOMPLETE in Ihren Vorlagen verwenden – dabei werden die Nachrichten vor dem Senden automatisch signiert.

    Signatur überprüfen

    Signierte Nachrichten werden mit dem Symbol in der Nachrichtenliste ausgezeichnet. Um die Signatur der Nachricht zu prüfen, wählen Sie die Option Signatur überprüfen im Menü Hilfsmittel -> Sicherheit (Tastenkombination Umschalt+Strg+C) oder klicken Sie auf das Icon auf der rechten Seite im Kopfzeilenbereich.


    Standard PGP/MIME

    PGP – ist die Abkürzung von Pretty Good Privacy.
    MIME – ist kurz für Multipurpose Internet Mail Extensions.

    Standard PGP/MIME sichert den Nachrichtenaustauch gemäß:
    • RFC 1991 PGP Message Exchange Formats
    • RFC 2015 MIME Security with Pretty Good Privacy (PGP)
    • RFC 2440 OpenPGP Message Format
    • RFC 3156 MIME Security with OpenPGP
    In The Bat! wird PGP/MIME für Signatur/Verschlüsselung verwendet, wenn:
    • Nachrichten Anlagen enthalten
    • Nachrichten das Format HTML oder RTF haben
    • Nachrichten ASCII-fremde Zeichen enthalten
    • Zeilen des Textes länger als 75 Zeichen sind
    • Mindesten eine Zeile mit „An“ beginnt
    • Zeilen des Textes Leerzeichen am Ende enthalten
    Achtung: Um die verschlüsselte Nachricht zu lesen, muss der Empfänger den privaten Schlüssel besitzen und das PGP-Programm installiert haben.
    Anmerkung: Einige E-Mail-Programme behandeln Nachrichten, die per PGP/MIME signiert sind, falsch. In diesen Fällen kann man das Makro %NOPGPMIME in der Vorlage verwenden.


    0  

    Anti-Junk-Plugins
    In The Bat! kann man auch Anti-Junk-Plugins integrieren. Diese Plugins helfen unerwünschte Nachrichten zu verwalten. Einige Plugins von Drittanbietern können Sie im Abschnitt Plugins sehen.

    Installieren Sie das Plugin und klicken Sie auf Hinzufügen im Menü Optionen -> Benutzereinstellungen -> Plugins -> Anti-Junk-Plugins. Wählen Sie die Datei *.TBP aus und klicken Sie auf Einstellungen, um die Plugin-Einstellungen vorzunehmen.



    Die Einstellung Zu verwendender Wert bei mehreren Plugins ist dann wichtig, wenn Sie mehr als ein Anti-Junk-Plugin installiert haben. Plugins können verschiedene Verfahren zur Berechnung von Werten verwenden. Wählen Sie den Wert - Mittelwert, Maximal oder Minimal - der für die weitere Aktionen gelten soll.

    Beispiel: Plugin A bestimmt den Wert 50, Plugin B - 70; wählen Sie Maximal, um 70 zu verwenden, Mittelwert, um 60 zu verwenden, und Minimal, um 50 zu verwenden.

    Legen Sie den Minimalwert für das Löschen der Junk-Nachricht fest – aktivieren Sie dafür zuerst die Option Junk-Nachricht löschen, wenn Wert größer als… Man kann auch den Minimalwert für das Verschieben der Nachricht in den Junk-Ordner bestimmen (Option Junk-Nachricht in Junk-Ordner verschieben, wenn Wert größer als). Der Junk-Ordner wird automatisch angelegt, wenn das Plugin die erste Junk-Nachricht erfasst.

    Ist die Option Junk-Nachricht in Junk-Ordner verschieben aktiviert, werden Nachrichten, die Sie manuell als Junk klassifizieren, auch in diesen Ordner verschoben.

    In jedem Ordner kann ein Junk-Ordner angelegt werden. Möchten Sie aber den gemeinsamen Ordner für Junk-Nachrichten einsetzen, aktivieren Sie die Option Gemeinsamen Junk-Ordner verwenden.

    Nachdem das Plugin installiert ist, müssen Sie es "trainieren", indem Sie ungefähr die gleiche Anzahl von Nachrichten "Als Junk" bzw."Als Nicht-Junk" klassifizieren. Wählen Sie eine Nachricht aus, machen Sie den Rechtsklick und wählen Sie eine der Optionen Als Junk/Nicht-Junk klassifizieren. Man kann Nachrichten auch über das Menü Extras im Hauptfenster des Programms als Junk/Nicht-Junk markieren. Man kann außerdem die Buttons in der Symbolleiste für diese Zwecke verwenden.


    0  

    Antivirus-Plugins
    The Bat! bietet die Möglichkeit, Antivirus-Plugins von Drittanbietern zu integrieren.

    Nachdem Sie das Antivirus-Plugin installiert haben, starten Sie The Bat! und klicken Sie auf den Button Hinzufügen im Menü Optionen -> Benutzereinstellungen -> Plugins -> Antivirus Plugins. Wählen Sie die Datei *.bav aus. Aktivieren Sie die Option Prüfung eingehender Nachrichten auf Viren.



    Setzen Sie das Häkchen bei Benachrichtigung an Absender schicken, um auf einer Vorlage basierende Benachrichtigungen über Viren an den Absender der Nachricht zu schicken. Man muss dabei in Betracht ziehen, dass die meisten Viren die Absenderadresse fälschen, deswegen ist es unwahrscheinlich, dass die Person, von deren Rechner Viren gesendet werden, diese Antwort erhält.

    Wählen Sie eine der Aktionen, die mit der infizierten Nachricht, durchgeführt wird:
    • Nachricht in Quarantäne-Ordner verschieben – Dieser Ordner wird beim Erhalt der ersten infizierten Nachricht automatisch angelegt;
    • Infizierte Bereiche versuchen zu reparieren – Lassen sich infizierte Bereiche nicht reparieren, wird die Nachricht gelöscht;
    • Infizierte Bereiche entfernen;
    • Nachricht an eigene Adresse weiterleiten;
    • Nachricht löschen.
    Ist die Option Prüfung von Dateianlagen, bevor sie in The Bat! geöffnet werden aktiviert, werden die Anlagen beim Öffnen geprüft. Ist das Häkchen bei Prüfung von Dateianlagen, bevor sie in The Bat! gespeichert werden aktiviert, werden die Dateien vor dem Speichern überprüft. Man kann auch ausgehende Nachrichten auf Viren prüfen.

    Antivirus-Plugins bieten möglicherweise zusätzliche Optionen. Klicken Sie auf Einstellungen, um sie aufzurufen. Verwenden Sie den Button Entfernen, um das Plugin zu löschen.


    0  

    Anlagensicherheit
    The Bat! öffnet angehängte Dateien nicht automatisch. Das Programm gibt eine Warnung aus, wenn Sie versuchen, die Datei zu öffnen, und schlägt vor, sie zuerst auf der Festplatte zu speichern. Halten Sie beim Doppelklick auf die Datei die Taste Umschalt gedrückt, wird die Datei ohne Warnung geöffnet.



    Im Menü Optionen -> Benutzereinstellungen -> Anlagensicherheit kann man bestimmen, welche Dateierweiterungen als gefährlich eingestuft werden. Selbstverständlich können Sie diese Angaben ändern.


    0  

    Datenschutz und Sicherheit
    Das E-Mail-Programm The Bat! bietet mehrere Funktionen an, um den Datenschutz- und Sicherheitsanforderungen Ihrer Korrespondenz Rechnung zu tragen.

    Um den Zugriff zum Konto einzuschränken, kann man es mit einem Passwort schützen. Das Konto-Passwort kann man über das Menü Konto -> Konto-Passwort setzen definieren (Tastenkombination Strg+F12). So können Sie den Zugriff zur Korrespondenz über die Benutzeroberfläche verwalten. Man kann auf das passwortgeschützte Konto nur nach der Eingabe des Passwortes zugreifen.

    In The Bat! Professional kann man auch die Nachrichtendatenbank, die auf dem Rechner gespeichert wird, verschlüsseln. Beim ersten Programmstart kann man die Verschlüsselung aktivieren und das Master-Passwort setzen. Alle Daten auf dem Rechner – Nachrichten, Adressbücher, Konfigurationsdateien - werden verschlüsselt. Dabei wird der Algorithmus AES in CBC-Verfahren mit 128 Bit Schlüssel verwendet. Man kann erst nach der Eingabe des Master-Passworts auf das Programm zugreifen. Das Master-Passwort kann man nicht ändern.

    In The Bat! Professional kann man auch Tokens verwenden.
    Hinweis: beim Verlust des Passworts oder des Tokens kann man nicht auf die verschlüsselte Nachrichtendatenbank zugreifen.

    Die Benutzer von The Bat! können OpenPGP oder S/MIME für Verschlüsseln und Signieren von Nachrichten verwenden, um die Sicherheit vertraulicher und persönlicher Daten zu gewährleisten. The Bat! unterstützt PGP bis Version 10.0.2 und S/MIME über die interne Implementierung oder Microsoft CryptoAPI.

    Weitere Sicherheitsmaßnahmen:
    • The Bat! öffnet die angehängten Dateien nicht automatisch. Hat die Datei eine doppelte Endung, z.B. photo.jpg.exe, gibt The Bat! vor dem Öffnen eine Warnung aus.
    • Ausführbare Dateien werden in The Bat! grundsätzlich nicht gestartet.
    • Der interne Viewer ignoriert Skripte und ausführbare Codes, so dass Viren keine Chance haben.
    • Der Bild-Download-Manager blockiert verdächtige Bilder in HTML-Nachrichten.
    • The Bat! bietet die Möglichkeit, Virenschutz- und Anti-Junk-Plugins zu integrieren.

    0